Project

General

Profile

Actions

Bug #2729

closed

oi-151.1.4 problems with SFEbuild and SFEencumbered

Added by r a over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2012-05-13
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

After upgrading to oi-151.1.4 I am unable to add Stellarium and VLC from the SFEbuild and SFEencumbered repositories. The installation fails due to incompatible links issue, details provided below. There is a conflict between the GCC 3.4.5 included as part of the OpenIndiana build and the SFE builds which use GCC 4.6. Should OpenIndiana Development be shipped with GCC 4.6?

Preparing...
Gathering package information

Error:
The requested change to the system attempts to install multiple actions
for link 'usr/bin/gcc' with conflicting attributes:

1 package delivers 'link path=usr/bin/gcc target=../gcc/4.6/bin/gcc':
pkg:,5.11-0.151.1:20111222T011404Z
1 package delivers 'link path=usr/bin/gcc target=../sfw/bin/gcc':
pkg:,5.11-0.151.1.4:20120502T222653Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

The requested change to the system attempts to install multiple actions
for link 'usr/bin/g++' with conflicting attributes:

1 package delivers 'link path=usr/bin/g++ target=../gcc/4.6/bin/g++':
pkg:,5.11-0.151.1:20111222T011404Z
1 package delivers 'link path=usr/bin/g++ target=../sfw/bin/g++':
pkg:,5.11-0.151.1.4:20120502T222653Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

The requested change to the system attempts to install multiple actions
for link 'usr/bin/gcov' with conflicting attributes:

1 package delivers 'link path=usr/bin/gcov target=../gcc/4.6/bin/gcov':
pkg:,5.11-0.151.1:20111222T011404Z
1 package delivers 'link path=usr/bin/gcov target=../sfw/bin/gcov':
pkg:,5.11-0.151.1.4:20120502T222653Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

Actions

Also available in: Atom PDF