Project

General

Profile

Bug #276

error when attempting to eject DVD from drive

Added by r a almost 9 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2010-09-28
Due date:
2011-09-14
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
needs-triage

Description

After inserting a DVD into a drive, a warning message "cannot mount volume" is display; however the DVD is mounted and can be accessed. When attempting to unmount the same drive as a normal user via the command line the folllowing error is displayed (GUI only reports "Cannot umount volume").

bash-4.0$ eject cdrom
eject of cdrom /dev/dsk/c4t0d0s2 failed: Rejected send message, 2 matched rules; type="method_call", sender=":1.113" (uid=101 pid=4664 comm="") interface="org.freedesktop.Hal.Device.Storage" member="Eject" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=458 comm=""))
bash-4.0$ pfexec eject cdrom
eject of cdrom /dev/dsk/c4t0d0s2 failed: Rejected send message, 2 matched rules; type="method_call", sender=":1.114" (uid=101 pid=4666 comm="") interface="org.freedesktop.Hal.Device.Storage" member="Eject" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=458 comm=""))
bash-4.0$

The DVD can only be ejected by becoming root

root@fred:~# eject cdrom

History

#1

Updated by Robin k almost 9 years ago

I can reproduce this bug.

#2

Updated by Albert Lee almost 9 years ago

  • Category changed from Desktop (JDS) to OS/Net (Kernel and Userland)
  • Target version deleted (oi_147)

Does this happen at the local console (I assume so, but just confirming)?

If you give your user the "Console User" profile (described here: http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6885612 ), does it still happen?

#3

Updated by William Bauer almost 9 years ago

I have upgraded three very different systems from build 134 to OpenIndiana (build 147), and have installed a clean OpenIndiana VM in VirtualBox. All four exhibit this bug not only with DVD/CD drives, but with USB hard drives and flash drives, both read-only and read-write. The Console User profile does nothing to mitigate the problem. You can only unmount as root (i.e. pfexec). And yes, all are console logins. All have also been 64-bit, although with Solaris that is a less significant issue than with others...!

Immediately upon inserting a disc, flash, or USB drive, it displays a "cannot mount" error, but mounts it anyway, and you cannot unmount/eject except as I described above. This is such a significant annoyance that I have gone back to my 134 install. So sad, because OI looks to be a nice project, and all my apps and scripts work otherwise unhindered.

#4

Updated by Andrew Stormont about 8 years ago

  • Difficulty set to Medium
  • Tags set to needs-triage

I am able to reproduce this bug with a kernel I checked out this morning.

#5

Updated by Andrew Stormont about 8 years ago

The only workaround I've found that works is 'sudo chmod $USER /dev/console'. After that it all magically starts working until the next reboot.

#6

Updated by Predrag Zečević about 8 years ago

Yes, this works.

BTW, there i s a typo in command above, should be
sudo chown $USER /dev/console

regrads and thanks.

#7

Updated by Julian Wiesener about 8 years ago

  • Assignee set to OI illumos
#8

Updated by Ken Mays about 8 years ago

  • Due date set to 2011-09-14
  • Status changed from New to Resolved
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

This was resolved. I verified it on oi_151a using:
--> pfexec eject cdrom
cdrom /dev/dsk/... ejected (cdrom drive ejects CD/DVD)

if you are not root or have root privs:
---> eject cdrom
eject of cdrom * failed (mounted by another user process))

Then, reinserted CD/DVD... no warning messages and proper mounting and display of CD/DvD contents.

This is on oi_151a. Please reopen if you update and still have further issues.

Also available in: Atom PDF