Project

General

Profile

Bug #2782

Basic write operation failed with the error "Device is gone"

Added by Manikandan Palanimuthu over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-05-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

Recently we have migrated our server to OpenIndiana(Build 151a3) running on DELL R710 Server.  During the time of installation, I found that, it takes too long time to detect the disk. Basically the local drive is in hardware RAID 1(mirror) of 250G disk. I have inbuilt RAID CARD: SAS 6/iR Integrated.
Also last couple of days,  if I perform a basic write operation of creating a 1G file through "mkfile 1g test.file", The server is completely hung and will not respond and I got the following error in the console* "scsi: WARNING: /pci@0,0/pci1028,235@a,7/hub@3/storage@2/disk@0,0 (sd23): command failed to complete...Device is gone"*. Also I have attached the error message as screenshot attachment.
I request you to please help on this issue. Also if you require any other information or log, please feel to revert to us on , .

Files

bkpfilerb01-error.jpg (271 KB) bkpfilerb01-error.jpg Manikandan Palanimuthu, 2012-05-25 08:15 AM
#1

Updated by Dieter Lange over 8 years ago

Have you checked for "TLER" (e.g. [[https://en.wikipedia.org/wiki/TLER]], this is the term used by WD, other brands use different names) ? Your drives need to report fast enough to the controller or it may consider them "gone".

#2

Updated by Manikandan Palanimuthu over 8 years ago

  • Status changed from New to In Progress

Hi Dieter Lange,

We have identified that the error thrown(Device is gone) was because of a removable media attached with the server locally, which we removed it now. 
Still we have the issue that, if we write on the local hard drive, it went for hung mode and we need to manually restart the server. For initial diagnosis, we took a call with DELL hardware support. DELL confirmed that there is no issue with the physical device.
Right now my setup is, 2 local drives(250G) in RAID 1(hardware mirror). Also I have a SSD Disk attached to the server directly. Initially at the time of openindiana installation, it took 5-10minute to detect the hard drive and after that last few days it goes for hung mode. Can you please suggest us, how to proceed further. is anything need to tweaked from OS side?

If you require log, please let us know. Right now this is completely affecting our environment.

Also I want to thank you for the interest towards our query.

#3

Updated by Dieter Lange over 8 years ago

Hi,

the "driver utility" program (upper left menu, "system tools") might give you hints about outdated/inappropriate drivers. Also you may have a look at [[http://hub.opensolaris.org/bin/view/Project+driver-utility/]]. More deeply involved individuals might have better help, though. Hardware support for OI certainly is (for a reason) not as broad as known from other, ubiquitous systems, so you may have to carefully compose your hardware for OI to get the most out of it.

Good luck !
DL

#4

Updated by Ken Mays almost 8 years ago

  • Status changed from In Progress to Closed

Please migrate this over to Illumos bug reporting. Duplicate issue with some bugs already reported there.

Also available in: Atom PDF