Bug #2827

subversion should use $(CC) when building perl modules

Added by Andrew Stormont almost 2 years ago. Updated almost 2 years ago.

Status:Resolved Start date:2012-06-04
Priority:Normal Due date:
Assignee:Andrew Stormont % Done:

100%

Category:-
Target version:-
Difficulty:Medium Tags:needs-triage

Description

Pretty simple. Subversion ignores $(CC) when building perl modules.

Proposed fix (save as ./components/subversion/patches/001-Makefile.PL.in.patch):

--- subversion/bindings/swig/perl/native/Makefile.PL.in.bak     2012-05-31 15:59:41.753371470 -0700
+++ subversion/bindings/swig/perl/native/Makefile.PL.in 2012-05-31 16:03:15.516177096 -0700
@@ -30,6 +30,7 @@
 my $apr_shlib_path_var = '@SVN_APR_SHLIB_PATH_VAR@';
 my $cppflags = '@CPPFLAGS@';
 my $cflags = '@CFLAGS@';
+my $cc = '@CC@';
 my $apr_cflags = '@SVN_APR_INCLUDES@';
 my $apu_cflags = '@SVN_APRUTIL_INCLUDES@';

@@ -44,6 +45,7 @@
     ABSTRACT => 'Perl bindings for Subversion',
     DEFINE => $cppflags,
     CCFLAGS => $cflags,
+    CC => $cc,
     INC  => join(' ',$apr_cflags, $apu_cflags, 
                  " -I$swig_srcdir/perl/libsvn_swig_perl",
                  " -I$svnlib_srcdir/include",

History

Updated by Andrew Stormont almost 2 years ago

  • Project changed from illumos-userland to illumian-userland
  • Assignee set to Andrew Stormont

Updated by Andrew Stormont almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed in 09c1502a3b65736ac565158664d549852e118dee.

Also available in: Atom PDF