Project

General

Profile

Actions

Bug #2850

closed

Russian locale does not need am/pm

Added by Igor Pashev about 10 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2012-06-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

--- ru_RU.UTF-8.src     2012-05-22 13:34:25.762739407 +0000
+++ ru_RU.UTF-8.src.fixed       2012-06-07 19:46:32.290526189 +0000
@@ -3182,9 +3182,9 @@

 d_t_fmt  "%e %B %Y<NO-BREAK_SPACE><CYRILLIC_SMALL_LETTER_GHE>. %H:%M:%S %Z" 

-am_pm    "<CYRILLIC_SMALL_LETTER_DE><CYRILLIC_SMALL_LETTER_O><space><CYRILLIC_SMALL_LETTER_PE><CYRILLIC_SMALL_LETTER_O><CYRILLIC_SMALL_LETTER_EL><CYRILLIC_SMALL_LETTER_U><CYRILLIC_SMALL_LETTER_DE><CYRILLIC_SMALL_LETTER_EN><CYRILLIC_SMALL_LETTER_YA>";"<CYRILLIC_SMALL_LETTER_PE><CYRILLIC_SMALL_LETTER_O><CYRILLIC_SMALL_LETTER_ES><CYRILLIC_SMALL_LETTER_EL><CYRILLIC_SMALL_LETTER_IE><space><CYRILLIC_SMALL_LETTER_PE><CYRILLIC_SMALL_LETTER_O><CYRILLIC_SMALL_LETTER_EL><CYRILLIC_SMALL_LETTER_U><CYRILLIC_SMALL_LETTER_DE><CYRILLIC_SMALL_LETTER_EN><CYRILLIC_SMALL_LETTER_YA>" 
+am_pm    "";"" 

-t_fmt_ampm  "%I:%M:%S %p" 
+t_fmt_ampm  "" 

 END LC_TIME
 *************
root@dyson:/home/illumos-gate/usr/src/cmd/localedef/data# 

Actions #1

Updated by Garrett D'Amore about 10 years ago

As the locale data for this was taken directly from CLDR, at the Unicode organization, we should work to fix that upstream. I'd prefer to avoid manually maintaining a set of "fixes" to data coming in from CLDR.

Actions #2

Updated by Yuri Pankov about 10 years ago

Better question is why this change is needed at all.

Actions #3

Updated by Igor Pashev about 10 years ago

Yuri Pankov wrote:

Better question is why this change is needed at all.

???

Cause ru_RU does use 24-hours time format

Actions #4

Updated by Yuri Pankov about 10 years ago

Ok. Now I see why you want this change, guess it's related to #2849 so that we could test *nl_langinfo(T_FMT_AMPM) != '\0' and select correct format string (12/24 hours). I'm worried that all other locales do define t_fmt_ampm though, should they be fixed as well (or is there another way to test if output should be 12 or 24 hours)?

Actions #5

Updated by Igor Pashev about 10 years ago

Yuri Pankov wrote:

Ok. Now I see why you want this change, guess it's related to #2849 so that we could test *nl_langinfo(T_FMT_AMPM) != '\0' and select correct format string (12/24 hours). I'm worried that all other locales do define t_fmt_ampm though, should they be fixed as well (or is there another way to test if output should be 12 or 24 hours)?

I'm not sure whether t_fmt_ampm should be empty, but I think it should not use %p in locales without am/pm notation.

If a user or a program wants 12-hours time it just gets it without am/pm

Actions #6

Updated by Yuri Pankov about 5 years ago

  • Status changed from New to Closed

Rereading this 5 years later, and it still doesn't make much sense. If you don't need the am/pm, simply don't use %p and %r format specifiers. Closing as not a bug.

Actions

Also available in: Atom PDF