Project

General

Profile

Actions

Bug #2965

closed

Samba SWAT fails PAM authentication due to missing symbol

Added by Siegfried Leonard over 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
-
Start date:
2012-07-05
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After installing samba and enabling its service and swat, I tried to go to http://localhost:901 and login as root. I noticed this in /var/samba/log/log.swat:

[2012/07/04 18:35:29.130860, 0] auth/pampass.c:577()
smb_pam_account: PAM: User root is NOT permitted to access system at this time
[2012/07/04 18:35:29.131133, 0] auth/pampass.c:829()
smb_pam_passcheck: PAM: smb_pam_account failed - Rejecting User root !

Looking at the system log, I also noticed this:

Jul 4 18:15:07 Serve swat2770: [ID 825731 auth.error] dlsym failed pam_sm_authenticate: error ld.so.1: swat: fatal: nspr_use_zone_allocator: can't find symbol
Jul 4 18:15:21 Serve mDNSResponder: [ID 702911 daemon.error] ERROR: getOptRdata - unknown opt 4
Jul 4 18:15:32 Serve swat2775: [ID 825731 auth.error] dlsym failed pam_sm_acct_mgmt: error ld.so.1: swat: fatal: nspr_use_zone_allocator: can't find symbol
Jul 4 18:15:32 Serve swat2775: [ID 264585 auth.error] load_modules[0:/etc/pam.conf]: pam_sm_acct_mgmt() missing

And I am unable to login with root, it gives me 401. The problem is reproducible every time. I hope the above is enough detail, if you need any more info, let me know.

Actions

Also available in: Atom PDF