Project

General

Profile

Bug #2969

SMB fails to join single label active directory domain

Added by Robert Brock over 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2012-07-05
Due date:
2014-02-14
% Done:

100%

Estimated time:
2.00 h
Difficulty:
Medium
Tags:
samba

Description

kclient and samba successfully join, but smb fails with the following messages in /var/adm/messages:

Jul 5 12:01:27 2hus291 smbd6810: [ID 358218 daemon.error] smbns_ksetpwd: KPASSWD failed: Authentication error
Jul 5 12:01:27 2hus291 smbd6810: [ID 526780 daemon.notice] Failed to establish NETLOGON credential chain
Jul 5 12:01:27 2hus291 smbd6810: [ID 871254 daemon.error] smbd: failed joining 2HUSHOU1 (UNSUCCESSFUL)

I have successfully joined 3 nexenta installations to this domain, so the issue is unique to OI and probably not a misconfiguration.

I don't mind standing up an OI vm and hosting a webex with an SMB guru interested in testing/rectifying this issue.

#1

Updated by Robert Brock over 8 years ago

I stood up a test VM AD domain with a proper name and it joined right up, so the issue is the single-label domain. I have wireshark dumps and truss files of failed AD join attempts available if they're needed, but I'd rather not post them up here...

#2

Updated by Ken Mays about 8 years ago

  • Assignee set to OI illumos
#3

Updated by Ken Mays about 7 years ago

  • Due date set to 2014-02-14
  • Category set to 10
  • Status changed from New to Closed
  • Assignee changed from OI illumos to OI Userland
  • % Done changed from 0 to 100
  • Estimated time set to 2.00 h
  • Tags changed from needs-triage to samba

Samba bumped to 3.6.22. Test procedures with Windows 2008/2012 setup. No major issues versus Linux setup.

Also helpful for Windows 8: http://superuser.com/questions/490453/how-can-i-connect-a-windows-8-pc-to-a-samba-domain

Maybe RFE for samba 4.1.x package for improved Win 8/8.1 support.
Closing ticket.

Also available in: Atom PDF