Project

General

Profile

Actions

Bug #2971

closed

Interrupt Balancer (intrd) doesn't start in oi_151a5

Added by Aleksander Włodarczyk about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OS/Net (Kernel and Userland)
Target version:
-
Start date:
2012-07-06
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Log says:

...
[ lip  6 11:19:41 Executing start method ("/lib/svc/method/svc-intrd"). ]
[ lip  6 11:19:41 Method "start" exited with status 0. ]
Sys::Syslog object version 0.22 does not match bootstrap parameter 0.29 at /usr/perl5/5.10.0/lib/i86pc-solaris-64int/Sys/Syslog.pm line 71.
Compilation failed in require at /usr/lib/intrd line 69.
[ lip  6 11:19:41 Stopping because all processes in service exited. ]
[ lip  6 11:19:41 Executing stop method (:kill). ]
[ lip  6 11:19:41 Restarting too quickly, changing state to maintenance. ]

Actions #1

Updated by Dieter Lange about 9 years ago

no such problem here (service starts and runs, no log entries), so maybe it is not the fault of oi_151prestable5/oi_151a5 ?

"perl -V":
Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
Platform:
osname=solaris, osvers=2.11, archname=i86pc-solaris-64int
uname='sunos localhost 5.11 i86pc i386 i86pc'
........
ccversion='Sun C 5.9 SunOS_i386 Patch 124868-07 2008/10/07', gccversion='', gccosandvers=''
........

Actions #2

Updated by Aleksander Włodarczyk about 9 years ago

My perl -V says:

Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
  Platform:
    osname=solaris, osvers=2.11, archname=i86pc-solaris-64int
    uname='sunos localhost 5.11 i86pc i386 i86pc'
    config_args=''
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_TS_ERRNO -DPERL_USE_SAFE_PUTENV',
    optimize='-xO3 -xspace -xildoff',
    cppflags=''
    ccversion='Sun C 5.9 SunOS_i386 Patch 124868-07 2008/10/07', gccversion='', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =''
    libpth=/lib /usr/lib /usr/ccs/lib
    libs=-lsocket -lnsl -ldl -lm -lc
    perllibs=-lsocket -lnsl -ldl -lm -lc
    libc=/lib/libc.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-R /usr/perl5/5.10.0/lib/i86pc-solaris-64int/CORE '
    cccdlflags='-KPIC', lddlflags='-G'

Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP
                        PERL_USE_SAFE_PUTENV USE_64_BIT_INT USE_LARGE_FILES
                        USE_PERLIO
  Built under solaris
  Compiled at Jun  6 2012 13:20:32
  @INC:
    /usr/perl5/site_perl/5.10.0/i86pc-solaris-64int
    /usr/perl5/site_perl/5.10.0
    /usr/perl5/vendor_perl/5.10.0/i86pc-solaris-64int
    /usr/perl5/vendor_perl/5.10.0
    /usr/perl5/vendor_perl
    /usr/perl5/5.10.0/lib/i86pc-solaris-64int
    /usr/perl5/5.10.0/lib
    .

Seems to be the same as Yours.
Previous boot environment (oi_151a4) starts without a glitch, so its definitely a fault of oi_151a5, but I cannot figure it out in what way...

Actions #3

Updated by Aleksander Włodarczyk about 9 years ago

Finally I was able to figure out what caused my troubles: newer versions of perl modules installed from CPAN.

After restoring pristine state of all perl related packages with pkg fix, all error messages have vanished.

Unfortunately, installed modules are very much outdated, for example IO version 1.23_01 is six years old now...

Actions #4

Updated by Jon Tibble about 9 years ago

  • Status changed from New to Closed

Closing this as not a bug with the distro. Perl updating is being looked at.

Actions

Also available in: Atom PDF