Project

General

Profile

Bug #2997

Raid 1 boot disk problems when booting OI_151.1.5

Added by r a over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2012-07-13
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
RAID-1

Description

Since upgrading to OI_151.1.5 I have experienced problems with the Raid 1 boot disk on my LSI 2411-4i constantly going into a degraded state. Initially I thought it was a disk problem and replaced the "faulty drive" but the problem remains. If I boot into the LSI controller bios and resynchronise the drives and performance a consistency check and then boot OI_151.1.5 it hangs. I have to power cycle my computer, which will then boot into OI_151.1.5 but it reports the Raid disk is in a degraded state.

If I boot into OI_151.1.4 then the problem does not occur, the disk will happily resychronise and boot normally without locking up the system.

#sas2ircu 0 display
LSI Corporation SAS2 IR Configuration Utility.
Version 5.00.00.00 (2010.02.09)
Copyright (c) 2009 LSI Corporation. All rights reserved.

Read configuration has been initiated for controller 0
------------------------------------------------------------------------
Controller information
------------------------------------------------------------------------
Controller type : SAS2004
BIOS version : 7.25.00.00
Firmware version : 13.00.57.00
Channel description : 1 Serial Attached SCSI
Initiator ID : 0
Maximum physical devices : 255
Concurrent commands supported : 1720
Slot : 5
Segment : 0
Bus : 3
Device : 0
Function : 0
RAID Support : Yes
------------------------------------------------------------------------
IR Volume information
------------------------------------------------------------------------
IR volume 1
Volume ID : 286
Status of volume : Degraded (DGD)
RAID level : RAID1
Size (in MB) : 237464
Physical hard disks :
PHY0 Enclosure#/Slot# : 1:3
PHY1 Enclosure#/Slot# : 1:2
------------------------------------------------------------------------
Physical device information
------------------------------------------------------------------------
Initiator at ID #0

Device is a Hard disk
Enclosure # : 1
Slot # : 2
State : Degraded (DGD)
Size (in MB)/(in sectors) : 238475/488397167
Manufacturer : ATA
Model Number : ST250DM000-1BD14
Firmware Revision : KC45
Serial No : 5VY87Z0M
Protocol : SATA
Drive Type : SATA_HDD

Device is a Hard disk
Enclosure # : 1
Slot # : 3
State : Optimal (OPT)
Size (in MB)/(in sectors) : 238475/488397167
Manufacturer : ATA
Model Number : ST3250410AS
Firmware Revision : A
Serial No : 6RYL4C26
Protocol : SATA
Drive Type : SATA_HDD
------------------------------------------------------------------------
Enclosure information
------------------------------------------------------------------------
Enclosure# : 1
Logical ID : 500605b0:0020670c
Numslots : 8
StartSlot : 0
------------------------------------------------------------------------
SAS2IRCU: Command DISPLAY Completed Successfully.
SAS2IRCU: Utility Completed Successfully.

  1. sas2ircu 0 status
    LSI Corporation SAS2 IR Configuration Utility.
    Version 5.00.00.00 (2010.02.09)
    Copyright (c) 2009 LSI Corporation. All rights reserved.

Background command progress status for controller 0...
IR Volume 1
Volume ID : 286
Current operation : Synchronize
Volume status : Enabled
Volume state : Degraded
Physical disk I/Os : Not quiesced
Volume size (in sectors) : 486326273
Number of remaining sectors : 442391937
Percentage complete : 9.03%
SAS2IRCU: Command STATUS Completed Successfully.
SAS2IRCU: Utility Completed Successfully.

History

#1

Updated by Ryo Murakawa over 7 years ago

  • Assignee set to Ryo Murakawa
  • Tags changed from needs-triage to RAID-1
#2

Updated by r a about 7 years ago

I deleted the OI_151.1.5 BE and then performed a second upgrade last week. The upgrade took place without fault and the first booting into OI_151.1.5 worked perfectly. After using OI_151.1.5 had been running for a few hours I took the opportunity to install SFEencumbered and SFE applications, before shutting down my computer.
The next time I attempted to boot OI_151.1.5 the boot process locked up and I need to power cycle my computer to regain access. The LSI Bios complained the RAID1 disk was in a degraded state and OI_151.1.5 boots into maintenance mode. After running "svcadm refresh boot-archive:default" and rebooting, OI_151.1.5 did boot normally.

#3

Updated by Ryo Murakawa about 7 years ago

The symptom was combination issue with your LSI BIOS and OI, I think.
If you did another action to find the workaround or root cause, Please share it with us.

#4

Updated by r a about 7 years ago

I have upgraded to OI151.1.6 and the problem of booting still remains. If the RAID1 pair is fully synchronised which will happen when I leave my desktop on for an extended period and then shutdown normally. When I first boot up my computer the boot process will freeze and the computer locks up, none of the keyboard keys will including "caps lock". If I power off my computer, wait and then restart. The LSI RAID1 controller complains the RAID1 set is degraded but the computer will boot every time. This was not the case with OI_151.1.5 where the boot process would hang occassionally when the RAID1 set is in a degraded state.

#5

Updated by Ryo Murakawa about 7 years ago

  • Assignee changed from Ryo Murakawa to OI Caiman

This issues is degraded.

#6

Updated by r a about 7 years ago

Last weekend I left my computer on for an extended period of time allowing the RAID1 disks to synchronise and for the filesystem to be scrubbed the computer worked fine and shutdown normally. When I started the computer on Tuesday, I left the computer for a couple of hours to see if the system was just slow. After four hours the computer had not completed its startup, so I powered of the computer. The next time I powered it on, the unit booted normally.

#7

Updated by r a about 7 years ago

After upgrading to OI_151a7 the problem still remains, OI_151a4 does not exhibit this problem.

#8

Updated by r a about 7 years ago

Upgraded to the latest LSI 9211-4i firmware Phase14 GCA Release Version 7.27.00.00 - SAS2BIOS_Phase14.0 (SCGCQ00300931) and the RAID1 boot disk was optimal and OI_151a7 booted normally. The boot issue appears to be resolved. I will need a a few more days to confirm if the problem been resolved.

#9

Updated by r a about 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

The LSI Raid controller has reported that the status of the RAID1 disk is optimal and OI_151a7 is booting normally. Upgrading the LSI Bios and Firmware to 9211_4i_Package_P14_IR_IT_Firmware_BIOS has corrected the problem.

#10

Updated by Ken Mays almost 7 years ago

  • Status changed from Feedback to Closed

Closing ticket based on user feedback.

Also available in: Atom PDF