Project

General

Profile

Bug #3015

lofiadm should use libz.so.1, not libz.so

Added by Igor Pashev almost 8 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
2012-07-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

History

#1

Updated by Igor Pashev almost 8 years ago

See #2698

#2

Updated by Igor Kozhukhov almost 8 years ago

have no dependencies on libz.so on my system with gcc44 build:

root@oi-vm:~# ldd /usr/sbin/lofiadm
libdevinfo.so.1 => /lib/libdevinfo.so.1
libpkcs11.so.1 => /usr/lib/libpkcs11.so.1
libcryptoutil.so.1 => /lib/libcryptoutil.so.1
libc.so.1 => /lib/libc.so.1
libnvpair.so.1 => /lib/libnvpair.so.1
libsec.so.1 => /lib/libsec.so.1
libgen.so.1 => /lib/libgen.so.1
libnsl.so.1 => /lib/libnsl.so.1
libavl.so.1 => /lib/libavl.so.1
libidmap.so.1 => /usr/lib/libidmap.so.1
libmp.so.2 => /lib/libmp.so.2
libmd.so.1 => /lib/libmd.so.1
libuutil.so.1 => /lib/libuutil.so.1
libm.so.2 => /lib/libm.so.2

#3

Updated by Gary Mills over 6 years ago

  • Status changed from New to Feedback
  • Assignee set to Gary Mills

I can fix this one.

#4

Updated by Gordon Ross over 6 years ago

  • Status changed from Feedback to Resolved
commit 6e096e64ab50f0e0567b99c4306fe9f3dead76e6
Author: Gary Mills <gary_mills@fastmail.fm>
Date:   Tue Jan 28 07:41:46 2014 -0600

    3015 lofiadm should use libz.so.1, not libz.so
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

3       2       usr/src/cmd/lofiadm/main.c

Also available in: Atom PDF