Project

General

Profile

Bug #3016

Kernel Panic with text install with HP Smart Array

Added by Adam Verslype almost 7 years ago. Updated over 6 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
-
Start date:
2012-07-22
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

When the text installer begins to write Openindiana to the E200 Smart Array on my HP Proliant DL385 g5, a kernel panic ensues. Some googling suggested it was the CPQary3 driver. I followed the advice on http://www.greenviolet.net/articles/2011/09/21/openindiana-151a-and-hp-smart-array-controllers.gv, and tried the newest driver and the driver version previous. Both produced the same error.

See screenshot


Files

2012-07-20_16.25.24.jpg (1.43 MB) 2012-07-20_16.25.24.jpg Adam Verslype, 2012-07-22 02:11 AM

Related issues

Related to illumos gate - Bug #2154: Panic DL460 G1 zpool create -f test c2t0d0s0Feedback2012-02-20

Actions
Related to illumos gate - Bug #348: ZFS should handle DKIOCGMEDIAINFOEXT failureResolved2010-10-152013-08-01

Actions
Related to OpenIndiana Distribution - Bug #1441: cpqary3 driver is old and causes panic in oi_151Closed2011-09-01

Actions

History

#1

Updated by Rich Lowe almost 7 years ago

  • Category set to OS/Net (Kernel and Userland)
  • Tags deleted (needs-triage)

This is almost certainly the same bad-ashift from DKIOCGMEDIAINFOEXT / READ_CAPACITY_16 response formats as the two bugs I just added to See Also.

Albert, weren't you working on a fix for this at some point? Is it in Nexenta's tree and easy to pluck out?

#2

Updated by Adam Verslype almost 7 years ago

Is there anything I can do re: this bug to help? My programming skills are a little bit rusty, but I could help with some basic stuff.

Strongly prefer Solaris to Linux/BSD, is there anything I can do about this bug in the meantime? Will cciss run on Solaris?

#3

Updated by Andy Giles almost 7 years ago

I have also come across this exact problem trying to install Openindiana u5 to a DL360 with an E200i Smart Array, 2 disks configured as a mirror. I will try some workarounds for now. Once it's installed I may be able to look at the problem.

#4

Updated by John Sloan almost 7 years ago

Hi folks,

I am having the same issue with an HP ML370 G3. Both Text and Live installer crashes just as it is booting up. I hope you guys can fix this soon!

#5

Updated by Ken Mays over 6 years ago

  • Assignee set to OI illumos

Also available in: Atom PDF