Bug #3043

zfs diff does not report removed files

Added by Chip Schweiss over 5 years ago. Updated over 3 years ago.

Status:FeedbackStart date:2012-07-30
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:zfs - Zettabyte File System
Target version:-
Difficulty:Medium Tags:needs-triage

Description

Assuming we should expect the same functionality as on Solaris files that are removed between snapshots should be listed with a '-'.

Currently a 'zfs diff' will only show the directory as modified that had a file removed. There will be no listing of the file that was removed.

History

#1 Updated by Daniil Lunev over 5 years ago

root@Exile:# zfs diff rpool/test@m1
M /rpool/test/mk
- /rpool/test/mk/testf

It seems to work as you have described.

#2 Updated by Chip Schweiss over 5 years ago

I'm working on OpenIndiana 151a4 and no deleted files or directories are showing up in zfs diff.

I will upgrade 151a5 and report back.

Would this be an OI or Illumos bug?

#3 Updated by Chip Schweiss over 5 years ago

Upgraded to 151a5 and the problem is fixed.

Sorry for reporting an already fixed bug.

#4 Updated by Daniil Lunev over 5 years ago

I have tested it with OI 151a5. Also, I have looked through the latest illumos-gate sources and it seems to show deleted files too.

#5 Updated by Yuri Pankov over 5 years ago

  • Status changed from New to Closed

#6 Updated by B T over 3 years ago

  • Status changed from Closed to Feedback

I believe this should be reopened. See this bug in zfsonlinux:
https://github.com/zfsonlinux/zfs/issues/2081

On OI 151a8, the commands below (copied from here ) produce the same incorrect result:

root@host:/% zfs create tank/test
root@host:/% cd /tank/test
root@host:/tank/test% touch a
root@host:/tank/test% zfs snapshot tank/test@1
root@host:/tank/test% zfs snapshot tank/test@2
root@host:/tank/test% rm a
root@host:/tank/test% zfs diff tank/test@1
M       /tank/test/
-       /tank/test/a
root@host:/tank/test% zfs diff tank/test@2
M       /tank/test/
root@host:/tank/test%

Also available in: Atom