Project

General

Profile

Bug #3046

crash on boot in zfs_rmnode

Added by Bart Coddens about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2012-08-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

My system dumps core during boot with this changeset:

38b4aca480b3 tip

I took three pictures of my screen when started under kmdb:

http://www.flickr.com/photos/26401511@N02/7692922520/

And then the msgbuf:

http://www.flickr.com/photos/26401511@N02/7692979674/in/photostream/
http://www.flickr.com/photos/26401511@N02/7692978898/in/photostream/

Kernel is built with the gcc4 compiler

prtdiag:

System Configuration:                                                                  
BIOS Configuration: Intel Corp. SOX5810J.86A.4405.2009.1020.1419 10/20/2009

==== Processor Sockets ====================================

Version                          Location Tag
-------------------------------- --------------------------
Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz J1PR

==== Memory Device Sockets ================================

Type        Status Set Device Locator      Bank Locator
----------- ------ --- ------------------- ----------------
Unknown     in use 0   J1MY                CHAN A DIMM 0
Unknown     in use 0   J2MY                CHAN A DIMM 1
Unknown     in use 0   J3MY                CHAN B DIMM 0
Unknown     in use 0   J4MY                CHAN C DIMM 0

==== On-Board Devices =====================================
Intel(R) 82567LM Gigabit Ethernet Device
Intel(R) High Definition Audio Device

==== Upgradeable Slots ====================================

ID  Status    Type             Description
--- --------- ---------------- ----------------------------
6   in use    Unknown          PCIE X16 SLOT 1
4   available Unknown          PCIE X16 SLOT 2
2   available Unknown          PCIE X4 SLOT
10  available PCI Express      PCIE X1 SLOT 1
11  available PCI Express      PCIE X1 SLOT 2
9   available PCI              PCI SLOT 1

zpool status:

 pool: rpool1
 state: ONLINE
status: The pool is formatted using a legacy on-disk format.  The pool can
        still be used, but some features are unavailable.
action: Upgrade the pool using 'zpool upgrade'.  Once this is done, the
        pool will no longer be accessible on software that does not support feature
        flags.
  scan: scrub repaired 0 in 0h7m with 0 errors on Wed Jul 18 17:36:48 2012
config:

        NAME        STATE     READ WRITE CKSUM
        rpool1      ONLINE       0     0     0
          c2t2d0s0  ONLINE       0     0     0

errors: No known data errors

  pool: store
 state: ONLINE
status: Some supported features are not enabled on the pool. The pool can
        still be used, but some features are unavailable.
action: Enable all features using 'zpool upgrade'. Once this is done,
        the pool may no longer be accessible by software that does not support
        the features. See zpool-features(5) for details.
  scan: scrub repaired 0 in 0h5m with 0 errors on Wed Jul 18 17:35:38 2012
config:

        NAME        STATE     READ WRITE CKSUM
        store       ONLINE       0     0     0
          mirror-0  ONLINE       0     0     0
            c2t0d0  ONLINE       0     0     0
            c2t5d0  ONLINE       0     0     0

If any more information is needed, please advise:

Related issues

Related to illumos gate - Feature #3006: VERIFY[S,U,P] and ASSERT[S,U,P] frequently check if first argument is zeroResolved2012-07-17

Actions

History

#1

Updated by Rich Lowe about 8 years ago

I'm seeing this too, and will take a look.

#2

Updated by Rich Lowe about 8 years ago

  • Subject changed from coredump on system boot when loading the zfs module to crash on boot in zfs_rmnode
#3

Updated by Rich Lowe about 8 years ago

The 'xzp->z_id' here should be 'zp->z_id', the xattr node may not exist, and has already been dealt with regardless:

http://src.illumos.org/source/xref/illumos-gate/usr/src/uts/common/fs/zfs/zfs_dir.c#675

#4

Updated by Rich Lowe about 8 years ago

  • Status changed from New to In Progress

This was caused by #3006, which I'll have backed out within an hour or so.

        /* Remove this znode from the unlinked set */
-       VERIFY3U(0, ==,
-           zap_remove_int(zfsvfs->z_os, zfsvfs->z_unlinkedobj, zp->z_id, tx));
+       VERIFY0(zap_remove_int(zfsvfs->z_os, zfsvfs->z_unlinkedobj,
+           xzp->z_id, tx));
#5

Updated by Rich Lowe about 8 years ago

  • Status changed from In Progress to Resolved

Resolved in r13765 commit:9410cf539b11

Also available in: Atom PDF