Project

General

Profile

Actions

Bug #3099

closed

AMD hudson D3 AHCI support

Added by John Huang about 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2012-08-20
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

151a5 not support AMD hudson D3 chipset AHCI.
AMD hudson D3 chipset AHCI device, the vendor id is 0x1022, device id is 0x7801, this AHCI is same as SB700/750 AHCI chipset. Add code:
if (ahci_ctlp->ahcictl_venid 0x1022 &&
ahci_ctlp->ahcictl_devid 0x7801) {
ahci_ctlp->ahcictl_cap |= AHCI_CAP_COMMU_32BIT_DMA;
ahci_ctlp->ahcictl_cap |= AHCI_CAP_SRST_NO_HOSTPORT;
}


Related issues

Is duplicate of illumos gate - Bug #3797: AHCI: Support for ASMedia ASM106xResolvedMarcel Telka2013-05-29

Actions
Is duplicate of illumos gate - Bug #3815: AHCI: Support for Marvell 88SE9128ResolvedMarcel Telka2013-06-14

Actions
Actions #1

Updated by Albert Lee almost 9 years ago

  • Project changed from OpenIndiana Distribution to illumos gate
Actions #2

Updated by Albert Lee almost 9 years ago

  • Category set to driver - device drivers

http://openindiana.org/pipermail/oi-dev/2012-August/001593.html has some additional discussion, as the proposed change does not appear to be sufficient.

Actions #3

Updated by Anonymous almost 9 years ago

http://openindiana.org/pipermail/oi-dev/2012-August/001593.html has a error, AMD AHCI vendor id is 0x1022, 0x1002 is ATI vendor ID.

Actions #4

Updated by Marcel Telka almost 8 years ago

  • Status changed from New to Feedback

Is this issue still reproducible with oi_151a8 ?

Actions #5

Updated by John Huang over 7 years ago

oi_151a8 is OK

Actions #6

Updated by John Huang over 7 years ago

  • Status changed from Feedback to In Progress
  • % Done changed from 0 to 100
Actions #7

Updated by Marcel Telka over 7 years ago

  • Assignee set to Marcel Telka

This is apparently a duplicate of #3797 and/or #3815.

Actions #8

Updated by Marcel Telka over 7 years ago

  • Assignee deleted (Marcel Telka)
  • Tags deleted (needs-triage)
Actions #9

Updated by Marcel Telka over 7 years ago

  • Status changed from In Progress to Feedback
Actions #10

Updated by Marcel Telka over 7 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF