Project

General

Profile

Bug #3122

zfs destroy filesystem should prefetch blocks

Added by Christopher Siden over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2012-08-24
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The new background destroy of filesystems doesn't prefetch blocks, which makes it quite slow. The problem is that the TRAVERSE_PREFETCH_METADATA doesn't actually work (metadata is not prefetched). So we need to fix the traversal code.

This is the destroy performance win Matt Aherns blogged in the second-to-last paragraph here:
http://blog.delphix.com/matt/2012/07/11/performance-of-zfs-destroy/

History

#1

Updated by Eric Schrock over 6 years ago

  • Status changed from In Progress to Resolved

changeset: 13792:4be8368f41e4
tag: tip
user: Matthew Ahrens <>
date: Fri Aug 31 07:26:05 2012 -0700

description:
3122 zfs destroy filesystem should prefetch blocks
Reviewed by: Christopher Siden <>
Reviewed by: George Wilson <>
Reviewed by: Adam Leventhal <>
Approved by: Garrett D'Amore <>

Also available in: Atom PDF