Project

General

Profile

Bug #3191

System->Administration->Services GUI Tool Missing

Added by Dormition Skete about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2012-09-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

I recently upgraded OpenIndiana from 151a to 151a6. This is pretty much a stock machine.

I'm not real set on using GUI tools to administer systems, but I noticed that my OpenIndiana box doesn't seem to have the "System->Administration->Services" GUI tool that used to ship with OpenSolaris.

Is this an oversight, or is this a known issue?

Or do I just need to install a package to get it? If so, which?

If I had an OpenSolaris box, I could look and see what the actual program name was, so I could search the OI repository easier - but, unfortunately, I don't.

And thank you all for your hard work on OpenIndiana!!!


Files

services.desktop (2.26 KB) services.desktop Dormition Skete, 2012-09-27 12:49 AM
shares.desktop (2.7 KB) shares.desktop Dormition Skete, 2012-09-27 12:49 AM

History

#1

Updated by Dormition Skete about 7 years ago

I looked into this, and found the attached two .desktop files in /usr/share/applications were empty. The files were there, but, for some reason, they were empty.

If you would include these two files in your upcoming releases in that directory, it should fix both the "Services" and the "Shared Folders" not showing up in the System->Administration menu.

#2

Updated by Fred Kimball about 7 years ago

Are either of these installed?

panel-smf SMF Service Administration GUI

panel-svcs SMF Services Administration GUI

#3

Updated by Dormition Skete about 7 years ago

No. Neither package is installed.

But I would think that if they would fix the problem, then they should be part of the standard desktop install.

The thing is, as far as I can tell, only the two desktop files appear to be needed to work properly. The packages you refer to appear to have other files in them that do not appear to be necessary - unless, of course, there's more to it than meets the eye.

Thanks for looking into this.

#4

Updated by Ken Mays over 6 years ago

  • Assignee set to Milan Jurik
#5

Updated by Dormition Skete over 6 years ago

I recently tested this with a freshly installed OpenIndiana 151a7 machine. No other packages had been installed. Both of these GUI tools seemed to work fine with only the two .desktop files added.

I, personally, will not ever use these tools. However, with OpenIndiana describing itself as a "General Purpose Solaris Distribution", and with it having such a large user base using it on workstations, I really think these two tools should be available for them to use. And with all it taking to make that possible is replacing two empty .desktop files -- application launchers -- with those taken from OpenSolaris 2009-06, I fail to see why that should not be done.

Unless, of course, these two files were intentionally emptied; but that appears unlikely.

I hope this helps!

Thanks.

#6

Updated by Ken Mays over 6 years ago

  • Assignee changed from Milan Jurik to OI JDS
#7

Updated by Milan Jurik about 6 years ago

  • Status changed from New to In Progress
  • Assignee changed from OI JDS to Milan Jurik
#8

Updated by Aurélien Larcher about 5 years ago

Hi,
The ticket applies to an old version of OpenIndiana and on hipster the issue is solved so I guess it was likely also gone in a9.
Maybe the ticket should be closed.
Best regards,

Aurelien

#9

Updated by Aurélien Larcher over 3 years ago

  • Tracker changed from Feature to Bug
  • Status changed from In Progress to Closed
  • Assignee changed from Milan Jurik to OI Userland

Fixed in later 151a.

Also available in: Atom PDF