Project

General

Profile

Actions

Bug #3274

closed

Can't upgrade packages from MBL publisher to sfe-encumbered version

Added by Karl Dag Gursli over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2012-10-11
Due date:
2013-12-10
% Done:

0%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
pkg

Description

I have problem with getting rid of the old MBL packages. Have tried several methods.
Here is a message from the update-refresh script.

Your "cron" job on araya
/usr/lib/update-manager/update-refresh.sh

produced the following output:

The following packages all deliver file actions to usr/bin/extract_dca:

pkg:,5.11:20090711T090951Z
pkg:,5.11-0.151.1.5:20120818T202601Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org origin online http://pkg.openindiana.org/dev/
sfe origin online http://pkg.openindiana.org/sfe/
sfe-encumbered origin online http://pkg.openindiana.org/sfe-encumbered/
ips.homeunix.com origin online http://ips.homeunix.com:10906/

Actions #1

Updated by Milan Jurik over 8 years ago

  • Status changed from New to Feedback

You need to uninstall packages from MBLrepo to be able to use sfe-encumbered.

Actions #2

Updated by Karl Dag Gursli over 8 years ago

Well if that was possible I had done it.
Here is a the result of the uninstall test:

gurslikd@araya:~ > sudo pkg uninstall MBLlibdca
Creating Planpkg uninstall: Cannot remove 'pkg:,5.11:20090711T090951Z' due to the following packages that depend on it:
pkg:,5.11:20090719T093954Z

gurslikd@araya:~ > sudo pkg uninstall MBLlibdca MBLmplayer
Packages to remove: 2
Packages to update: 6
Create boot environment: No
Create backup boot environment: No

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

http protocol error: code: 404 reason: Not Found
URL: 'http://pkg.openindiana.org/sfe-encumbered/file/1/48a742264fa243ffacddec3522924a3d31626d71'. (happened 4 times)

This is happening because the following packages needed to be repaired as
part of this operation:

pkg:,5.11-0.151.1:20111025T205523Z

You will need to reestablish your access to the repository or remove the
packages in the list above.
gurslikd@araya:~ > sudo pkg uninstall mplayer
Creating Plan
pkg uninstall: 'mplayer' matches no installed packages

gurslikd@araya:~ > sudo pkg uninstall media/mplayer
Creating Plan
pkg uninstall: 'media/mplayer' matches no installed packages

gurslikd@araya:~ >

Actions #3

Updated by Karl Dag Gursli over 8 years ago

Well if that was possible I had done it.
Here is a the result of the uninstall test:

gurslikd@araya:~ > sudo pkg uninstall MBLlibdca
Creating Planpkg uninstall: Cannot remove 'pkg:,5.11:20090711T090951Z' due to the following packages that depend on it:
pkg:,5.11:20090719T093954Z
gurslikd@araya:~ > sudo pkg uninstall MBLlibdca MBLmplayer
Packages to remove: 2
Packages to update: 6
Create boot environment: No
Create backup boot environment: No
Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

http protocol error: code: 404 reason: Not Found
URL: 'http://pkg.openindiana.org/sfe-encumbered/file/1/48a742264fa243ffacddec3522924a3d31626d71'. (happened 4 times)

This is happening because the following packages needed to be repaired as
part of this operation:
pkg:,5.11-0.151.1:20111025T205523Z

You will need to reestablish your access to the repository or remove the
packages in the list above.
gurslikd@araya:~ > sudo pkg uninstall media/mplayer2
Creating Plan /
pkg uninstall: The requested change to the system attempts to install multiple actions
for dir 'usr/share/doc' with conflicting attributes:

1 package delivers 'dir group=bin mode=0755 owner=root path=usr/share/doc':
pkg:,5.11:20090604T101928Z
201 packages deliver 'dir group=other mode=0755 owner=root path=usr/share/doc', including:
pkg:,5.11-0.151.1.3:20120329T222544Z
pkg:,5.11-0.151.1.3:20120329T211216Z
pkg:,5.11-0.151.1.3:20120329T211159Z
pkg:,5.11-0.151.1.3:20120329T211220Z
pkg:,5.11-0.151.1.3:20120329T211224Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

The requested change to the system attempts to install multiple actions
for dir 'usr/share' with conflicting attributes:

6 packages deliver 'dir group=bin mode=0755 owner=root path=usr/share', including:
pkg:,5.11:20090604T101826Z
pkg:,5.11:20090604T101928Z
pkg:,5.11:20090711T090951Z
pkg:,5.11:20090719T061221Z
pkg:,5.11:20090711T090838Z
460 packages deliver 'dir group=sys mode=0755 owner=root path=usr/share', including:
pkg:,5.11-0.151.1.3:20120329T222544Z
pkg:,5.11-0.151.1.3:20120329T211158Z
pkg:,5.11-0.151.1.3:20120329T221312Z
pkg:,5.11-0.151.1.3:20120329T211216Z
pkg:,5.11-0.151.1.3:20120329T211159Z

These packages may not be installed together. Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

gurslikd@araya:~ >

Actions #4

Updated by Ken Mays over 7 years ago

  • Due date set to 2013-12-10
  • Status changed from Feedback to Closed
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to pkg

Can't duplicate due to closure of MBLrepo. Issue observed was conflicting packages which is resolved in other pkgmgrs by using a specific folder for personal/ISV projects isolated from core or SFE-related packages (unless just larger apps built from those projects versus libraries). Best to review porting documents based on this issue to resolve in future porting projects - which will help avoid this issue.

Actions

Also available in: Atom PDF