Project

General

Profile

Bug #3349

zpool upgrade -V bumps the on disk version number, but leaves the in core version

Added by Christopher Siden almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2012-11-08
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

From John Kennedy's original bug report at Delphix:

To reproduce:

zpool create -o version=5 data c2t1d0
zpool upgrade -V 9 data

...at this point, ::spa and zdb -C will say '5', while 'zpool upgrade'
will say 9.

The problem is that the spa config is not being updated when the new version gets synced out.

History

#1

Updated by Christopher Siden almost 7 years ago

  • Status changed from New to Closed
commit 25345e466695fbe736faa53b8f3413d8e8f81981
Author: George Wilson <george.wilson@delphix.com>
Date:   Fri Nov 9 14:46:41 2012 -0800

    3349 zpool upgrade -V bumps the on disk version number, but leaves the in core version
    Reviewed by: Adam Leventhal <ahl@delphix.com>
    Reviewed by: Christopher Siden <chris.siden@delphix.com>
    Reviewed by: Matt Ahrens <matthew.ahrens@delphix.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@nexenta.com>

Also available in: Atom PDF