Project

General

Profile

Actions

Bug #3377

closed

pkg install freetype-2@latest rejected by openindiana.org

Added by Brent Wagner almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2012-11-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

Introduction

On a fresh installation of oi_151.1.5 X86 with the openindiana.org publisher, attempts to install the latest freetype-2 package fail:

root@ftp:~# pkg install freetype-2@latest
Creating Plan /
pkg install: No matching version of system/library/freetype-2 can be installed:
Reject: pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z

Additional Output

root@ftp:~# pkg info -r freetype-2
Name: system/library/freetype-2
Summary: FreeType 2 font engine
Description: FreeType 2 is a software font engine that is designed to be
small, efficient, highly customizable, and portable while
capable of producing high-quality output (glyph images). It can
be used in graphics libraries, display servers, font conversion
tools, text image generation tools, and many other products as
well.
Category: System/Libraries
State: Not installed
Publisher: openindiana.org
Version: 2.4.9
Build Release: 5.11
Branch: 0.151.1.7
Packaging Date: Wed Oct 3 23:08:23 2012
Size: 3.44 MB
FMRI: pkg:,5.11-0.151.1.7:20121003T230823@Z

root@ftp:~# pkg install pkg:,5.11-0.151.1.7:20121003T230823Z
Creating Plan /
pkg install: No matching version of system/library/freetype-2 can be installed:
Reject: pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z

Without specifying a version (pkg install freetype-2), freetype-2 v2.4.4 is installed, which does not satisfy the php-52 dependency in the amp stack, causing "pkg install amp" to also fail. See below for full output.

OS Details

root@ftp:~# cat /etc/release
OpenIndiana Development oi_151.1.5 X86 (powered by illumos)
Copyright 2011 Oracle and/or its affiliates. All rights reserved.
Use is subject to license terms.
Assembled 26 June 2012

Full Output of Failed AMP Installation

root@ftp:~# pkg install amp
Creating Plan \\\\
pkg install: No solution was found to satisfy constraints

maintained incorporations:

pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223920Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223912Z
pkg:,5.11-0.151.1.7:20121003T223906Z
pkg:,5.11-0.151.1.5:20120630T192657Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T192702Z
pkg:,5.11-0.151.1.7:20121003T223921Z
pkg:,5.11-0.151.1.5:20120630T192658Z
pkg:,5.11-0.151.1:20110912T030804Z
pkg:,5.11-0.151.1.5:20120630T192708Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223907Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
Plan Creation: dependency error(s) in proposed packages:

No suitable version of required package pkg:,5.11-0.151.1.5:20120630T191328Z found:
Reject: pkg:,5.11-0.151.1.5:20120630T191328Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T191045Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T195609Z
pkg:,5.11-0.151.1.6:20120902T093951Z
pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z
Reject: pkg:,5.11-0.151.1.6:20120902T085329Z
pkg:,5.11-0.151.1.7:20121003T222212Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
No suitable version of required package pkg:,5.11-0.133:20120329T215246Z found:
Reject: pkg:,5.11-0.133:20120329T215246Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.3 are rejected
Reject: pkg:,5.11-0.151.1.3:20120329T215246Z
pkg:,5.11-0.151.1.4:20120502T231742Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
Reject: pkg:,5.11-0.151.1.5:20120630T191328Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T191045Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T195609Z
pkg:,5.11-0.151.1.6:20120902T093951Z
pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z
Reject: pkg:,5.11-0.151.1.6:20120902T085329Z
pkg:,5.11-0.151.1.7:20121003T222212Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
Reject: pkg:,5.11-0.151.1.6:20120902T085559Z
pkg:,5.11-0.151.1.7:20121003T222432Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
No suitable version of required package pkg:,5.11-0.133:20120502T231742Z found:
Reject: pkg:,5.11-0.133:20120502T231742Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.4 are rejected
Reject: pkg:,5.11-0.151.1.4:20120502T231742Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
Reject: pkg:,5.11-0.151.1.5:20120630T191328Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T191045Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T195609Z
pkg:,5.11-0.151.1.6:20120902T093951Z
pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z
Reject: pkg:,5.11-0.151.1.6:20120902T085329Z
pkg:,5.11-0.151.1.7:20121003T222212Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
Reject: pkg:,5.11-0.151.1.6:20120902T085559Z
pkg:,5.11-0.151.1.7:20121003T222432Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z

Actions #1

Updated by Jon Tibble almost 9 years ago

  • Status changed from New to Feedback

It's trying to pull in the latest version (which is prestable7 - 0.151.1.7 currently) as you didn't specify one. What do you get if you try the command below?

pkg install -vn

(take the -n away if it works and you want to actually perform the install)

Actions #2

Updated by Brent Wagner almost 9 years ago

Thanks for the suggestion, but the result is the same.

root@ftp:~# pkg install -vn
Creating Plan \\
pkg install: No solution was found to satisfy constraints

maintained incorporations:

pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223920Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223912Z
pkg:,5.11-0.151.1.7:20121003T223906Z
pkg:,5.11-0.151.1.5:20120630T192657Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T192702Z
pkg:,5.11-0.151.1.7:20121003T223921Z
pkg:,5.11-0.151.1.5:20120630T192658Z
pkg:,5.11-0.151.1:20110912T030804Z
pkg:,5.11-0.151.1.5:20120630T192708Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.7:20121003T223907Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z
pkg:,5.11-0.151.1.5:20120630T191329Z

Plan Creation: dependency error(s) in proposed packages:

No suitable version of required package pkg:,5.11-0.151.1.5:20120630T191328Z found:
Reject: pkg:,5.11-0.151.1.5:20120630T191328Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T191045Z
Reason: All versions matching 'require' dependency pkg:,5.11-0.151.1.5 are rejected
Reject: pkg:,5.11-0.151.1.5:20120630T195609Z
pkg:,5.11-0.151.1.6:20120902T093951Z
pkg:,5.11-0.151.1.7:20121003T230823Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1:20110912T030804Z
Reject: pkg:,5.11-0.151.1.6:20120902T085329Z
pkg:,5.11-0.151.1.7:20121003T222212Z
Reason: This version is excluded by installed incorporation pkg:,5.11-0.151.1.5:20120630T191329Z
Actions #3

Updated by Brent Wagner almost 9 years ago

I should have mentioned this only happens in a basic non-global zone

Actions #4

Updated by Jon Tibble almost 9 years ago

Your install is messed up. If you look at the list of maintained consolidations your X is only at 0.151.1 and you have a few stray consolidations at 0.151.1.7.

At some point an update hasn't completed fully. You should try and get all the consolidations to 0.151.1.5 (or 0.151.1.7) first then come back to look at amp.

Actions #5

Updated by Jon Tibble over 8 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF