Project

General

Profile

Bug #338

keyboard layout setting not working

Added by Petri Kunnari about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Start date:
2010-10-12
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

up to rev 13205 been trying to get keyboard layout to finnish
followed svc based setup and also did eeprom setup.

this maybe coming from X not in same level than onv.
as when use in x session from console , totally unable to select/add any layout for keyboard in input methoods.

when used openindiana b147 eeprom and svccfg did work.

is there some compatibility issue or just current packages installed based on gate wiki instructions for building not compatible what comes to x and gnome.

Thanks


Related issues

Is duplicate of illumos gate - Bug #310: svc:/system/keymap ignores eeprom layoutNew2010-10-06

Actions

History

#1

Updated by Albert Lee about 9 years ago

Update from IRC:
<pjk> in input methoods all keyboard layout selections are empty
<pjk> in openidiana i did this work , but setup by build instructions not...
<pjk> could it be incompatible packages as onv is newer than x ....
<pjk> will try that setxkmbmap ...

#2

Updated by Petri Kunnari about 9 years ago

Albert Lee wrote:

Update from IRC:
<pjk> in input methoods all keyboard layout selections are empty
<pjk> in openidiana i did this work , but setup by build instructions not...
<pjk> could it be incompatible packages as onv is newer than x ....
<pjk> will try that setxkmbmap ...

setxkmbmap did not have any affect.
stick in to EN keyboard.

#3

Updated by Garrett D'Amore about 9 years ago

  • Assignee set to Albert Lee

Trisk, I think this is probably a dup of one of the bugs you've been working on. Can you confirm, and close if appropriate (and put a reference to it here?)

Thanks.

#4

Updated by Albert Lee about 9 years ago

I think this may be related to locale changes that would've happened on a system, rather than the default keyboard layout.

#5

Updated by Albert Lee about 9 years ago

I meant to say, "on a system onu'd to illumos".

#6

Updated by Petri Kunnari about 9 years ago

Albert Lee wrote:

I meant to say, "on a system onu'd to illumos".

Hi
just builded illumos-gate rev 13216 using openindiana b147 working bootenv.
onu'd with illumos-gate build and init 6..
system says error about setting locales not working..
also keyboard setting resetted to US english
Managed to locales work based on garret's instructions about removing system/local pkg's and install new locale pkg's.. but did not get keyboard to work.. it keeped US english.
Thanks.

#7

Updated by Garrett D'Amore over 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF