Project

General

Profile

Feature #3432

Cadmium should support mercurial 1.8.4

Added by Marcel Telka almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
tools - gate/build tools
Start date:
2012-12-28
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

$ hg --version
*** failed to import extension hgext.cdm from /opt/onbld/lib/python/onbld/hgext/cdm.py: Version Mismatch:
 Scm expects Mercurial version 1.3.1, 1.4.2, 1.5.4, 1.6.2, 1.6.3, 1.7.5, 1.8 or 1.8.1, actual version is 1.8.4.

Mercurial Distributed SCM (version 1.8.4)
(see http://mercurial.selenic.com for more information)

Copyright (C) 2005-2011 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
$

Related issues

Is duplicate of illumos gate - Bug #1843: add new mercutial version 1.8.4 to toolsNew2011-12-02

Actions
#1

Updated by Rich Lowe almost 8 years ago

Should just be a matter of you allowing that version, and running the tests (http://bitbucket.org/richlowe/il-scmtest).

Really, someone should do the work to support Mercurial 2.x, but nobody has seemed interested.

#2

Updated by Marcel Telka almost 8 years ago

  • Status changed from New to Closed

Closing as duplicate of Bug #1843.

Also available in: Atom PDF