Project

General

Profile

Bug #3456

time-sliderd shouldn't monitor all zpools

Added by Marcel Telka over 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-01-09
Due date:
2013-12-31
% Done:

100%

Estimated time:
4.00 h
Difficulty:
Medium
Tags:
jds

Description

I have a zpool with some zvols. The zpool is almost full and it is configured to not be automatically snapshotted:

$ zpool list ns-bld
NAME     SIZE  ALLOC   FREE  EXPANDSZ    CAP  DEDUP  HEALTH  ALTROOT
ns-bld    57G  10,1G  46,9G         -    17%  1.00x  ONLINE  -
$ zfs get -r com.sun:auto-snapshot ns-bld
NAME        PROPERTY               VALUE                  SOURCE
ns-bld      com.sun:auto-snapshot  -                      -
ns-bld/ns3  com.sun:auto-snapshot  -                      -
ns-bld/ns4  com.sun:auto-snapshot  -                      -
$ zfs get -r type ns-bld
NAME        PROPERTY  VALUE       SOURCE
ns-bld      type      filesystem  -
ns-bld/ns3  type      volume      -
ns-bld/ns4  type      volume      -
$ zfs get -r volsize ns-bld
NAME        PROPERTY  VALUE    SOURCE
ns-bld      volsize   -        -
ns-bld/ns3  volsize   26G      local
ns-bld/ns4  volsize   28G      local
$

The problem is that the time-sliderd is monitoring this zpool and it is periodically generating the following messages:

Jan  9 03:38:32 telcontar time-sliderd: [ID 702911 daemon.emerg] ns-bld is over 95% capacity. All automatic snapshots were destroyed

The time-sliderd shouldn't generate such messages for zpools where it is not going to create snapshots.

Workaround:

# zpool export ns-bld
# svcadm restart svc:/application/time-slider:default
# zpool import ns-bld
#

History

#1

Updated by Ken Mays over 7 years ago

  • Status changed from New to Feedback
  • Assignee changed from Guido Berhörster to Milan Jurik

Please update to the http://pkg.opensolaris.cz/osol/en/index.shtml maintained by Milan Jurik and recheck time-slider issues.

#2

Updated by Ken Mays over 7 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (Milan Jurik)
  • % Done changed from 0 to 100

Closed ticket. Based on provided user workaround. This will get added to wiki for time-slider debugging.

#3

Updated by Marcel Telka almost 7 years ago

  • Status changed from Closed to In Progress

An existing workaround is not enough to close a bug. Reopening.

#4

Updated by Ken Mays almost 7 years ago

  • Due date set to 2013-12-31
  • Assignee set to Milan Jurik
  • % Done changed from 100 to 0
  • Estimated time set to 4.00 h
  • Tags changed from needs-triage to jds
#5

Updated by Ken Mays about 6 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Seems fixed in hipster-20140701, tested w/ ,5.11-2014.1.0.97:20140622T140045Z.

No major errors.

Also available in: Atom PDF