Project

General

Profile

Actions

Bug #3508

closed

NFS4 data corruption (client side)

Added by Arne Jansen over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
nfs - NFS server and client
Start date:
2013-01-30
Due date:
% Done:

0%

Estimated time:
Difficulty:
Hard
Tags:
needs-triage
Gerrit CR:

Description

When writing to a file, from time to time some data don't make it to the server. Instead, a hole is left in the file. If the file is opened with O_APPEND, the file pointer jumps back instead and overwrites data.
It only occurs when the file is written with medium speed and the server reacts slow from time to time. A small C-program to reproduce the problem is attached.
The problem is basically that the client accepts r_size updates even though it has outstanding writes.
Webrev to follow.


Files

small_write.c (764 Bytes) small_write.c Arne Jansen, 2013-01-30 02:02 PM
Actions #1

Updated by Gordon Ross over 8 years ago

  • Status changed from New to Resolved
From aea676fd5203d93bed37515d4f405d6a31c21509 Mon Sep 17 00:00:00 2001
From: Arne Jansen <sensille@gmx.net>
Date: Wed, 30 Jan 2013 13:18:22 +0100
Subject: [PATCH] 3508 NFS4 data corruption (client side)
 Reviewed by: Marcel Telka <marcel@telka.sk>
 Reviewed by: Robert Gordon <rbg@openrbg.com>
 Approved by: Gordon Ross <gwr@nexenta.com>
Actions

Also available in: Atom PDF