Project

General

Profile

Bug #3510

libwrap 64 bit build failed

Added by Igor Kozhukhov over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Start date:
2013-01-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/tools/proto/root_i386-nd/opt/onbld/bin/i386/cw -_gcc -xO3 -m64 -Ui386 -U__i386  -Xa  -xildoff -errtags=yes -errwarn=%all -erroff=E_EMPTY_TRANSLATION_UNIT -erroff=E_STATEMENT_NOT_REACHED -_gcc=-Wno-missing-braces -_gcc=-Wno-sign-compare -_gcc=-Wno-unknown-pragmas -_gcc=-Wno-unused-parameter -_gcc=-Wno-missing-field-initializers -_gcc=-Wno-array-bounds -erroff=E_FUNC_EXPECTS_TO_RETURN_VALUE -erroff=E_IMPLICIT_DECL_FUNC_RETURN_INT -erroff=E_OLD_STYLE_DECL_HIDES_PROTO -_gcc=-Wno-return-type -_gcc=-Wno-parentheses -_gcc=-Wno-unused-variable -_gcc=-Wno-uninitialized -xc99=%none    -W0,-xglobalstatic -_gcc=-fno-inline-small-functions  -_gcc=-fno-inline-functions-called-once  -_gcc=-fno-ipa-cp -o libwrap.so.1.0 -G -hlibwrap.so.1 -ztext -zdefs -Bdirect  -M../mapfile -M/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/common/mapfiles/common/map.pagealign -M/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/common/mapfiles/common/map.noexdata  pics/hosts_access.o pics/options.o pics/shell_cmd.o pics/rfc931.o pics/eval.o  pics/hosts_ctl.o pics/refuse.o pics/percent_x.o pics/clean_exit.o  pics/fromhost.o pics/fix_options.o pics/socket.o pics/tli.o pics/workarounds.o  pics/update.o pics/misc.o pics/diag.o pics/percent_m.o pics/libvars.o  -L /myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/usr/lib/amd64 -L/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/lib/amd64 -L/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/usr/lib/amd64   -lsocket -lnsl -lc
+ /usr/gcc/4.4/bin/gcc -fident -finline -fno-inline-functions -fno-builtin -fno-asm -fdiagnostics-show-option -nodefaultlibs -D__sun -fno-strict-aliasing -fno-unit-at-a-time -fno-optimize-sibling-calls -O2 -m64 -mtune=opteron -Ui386 -U__i386 -Wall -Wextra -Werror -Wno-m-Wno-uninitialized -std=gnu89 -fno-inline-small-functions -fno-inline-functions-called-once -fno-ipa-cp -o libwrap.so.1.0 -shared -hlibwrap.so.1 -Wl,-ztext -Wl,-zdefs -Wl,-Bdirect -Wl,-M../mapfile -Wl,-M/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/common/mapfiles/common/map.pagealign -Wl,-M/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/common/mapfiles/common/map.noexdata pics/hosts_access.o pics/options.o pics/shell_cmd.o pics/rfc931.o pics/eval.o pics/hosts_ctl.o pics/refuse.o pics/percent_x.o pics/clean_exit.o pics/fromhost.o pics/fix_options.o pics/socket.o pics/tli.o pics/workarounds.o pics/update.o pics/misc.o pics/diag.o pics/percent_m.o pics/libvars.o -L /myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/usr/lib/amd64 -L/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/lib/amd64 -L/myshare/builds/dilos-illumos-gate/dilos-illumos-gate/proto/root_i386/usr/lib/amd64 -lsocket -lnsl -lc 
Undefined                       first referenced
 symbol                             in file
sys_nerr                            pics/tli.o
sys_errlist                         pics/tli.o
ld: fatal: symbol referencing errors. No output written to libwrap.so.1.0
collect2: ld returned 1 exit status
*** Error code 1
dmake: Fatal error: Command failed for target `libwrap.so.1.0'
Current working directory /myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/lib/libwrap/amd64
*** Error code 1
The following command caused the error:
cd amd64; pwd; dmake install
dmake: Fatal error: Command failed for target `amd64'
Current working directory /myshare/builds/dilos-illumos-gate/dilos-illumos-gate/usr/src/lib/libwrap

Related issues

Related to illumos gate - Bug #1666: libwrap is 32bit onlyResolved2011-10-18

Actions

History

#1

Updated by Yuri Pankov over 7 years ago

There doesn't seem to be an amd64 target for libwrap in illumos-gate.

#2

Updated by Rich Lowe over 7 years ago

  • Status changed from New to Feedback
  • Priority changed from Normal to Low

Right, if this is an RFE for a 64bit libwrap, you should update it so it makes that clear.

The fact you've tried to add a 64bit build and failed is not a bug in illumos.

#3

Updated by Andrew Stormont over 7 years ago

Look at the patch I attached to #1666. Not sure if it's correct but it seemed to do the trick for me.

#4

Updated by Igor Kozhukhov over 7 years ago

this bug can be closed if not applicable for illumos.
i have ported 'tcp-wrappes' to DilOS and will use it for OpenSSH instead of libwrap from illumos.

#5

Updated by Yuri Pankov over 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF