Project

General

Profile

Feature #3522

zfs module should not allow uninitialized variables

Added by Christopher Siden over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2013-02-02
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The initial fix for '3236 zio nop-write' had a bug in it caused by uninitialized variables that could have been avoided if the ZFS kernel module could be compiled with gcc warnings for uninitialized variables. We should make the changes necessary to the code to enable those warnings in ZFS.

History

#1

Updated by Christopher Siden over 6 years ago

  • Status changed from In Progress to Closed
commit d5285ca
Author: George Wilson <george.wilson@delphix.com>
Date:   Sun Feb 10 22:21:05 2013

    3522 zfs module should not allow uninitialized variables
    Reviewed by: Sebastien Roy <seb@delphix.com>
    Reviewed by: Adam Leventhal <ahl@delphix.com>
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF