Project

General

Profile

Bug #3550

html pages generated by webrev(1) should force utf-8 encoding

Added by Marcel Telka over 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-02-11
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

Currently the html pages generated by webrev(1) does not contain any information about encoding. In case the bug synopsis and/or reviewer's name contains non-ASCII characters the browser will use some default encoding. This might lead to incorrect rendering of some characters.

For example my browser showed this by default (ISO-8859-2 was selected automatically):

3501 mdb: ::thread -d needs the SWITCH column
Reviewed by: David HĂśppner <0xffea@gmail.com>

While the correct (with UTF-8 encoding) should be:

3501 mdb: ::thread -d needs the SWITCH column
Reviewed by: David Höppner <0xffea@gmail.com>

Related issues

Is duplicate of illumos gate - Feature #4907: webrev should default to utf-8Closed2014-06-03

Actions

History

#1

Updated by Yuri Pankov almost 6 years ago

  • Status changed from New to Closed

Done in #4907.

Also available in: Atom PDF