Project

General

Profile

Bug #361

xpg4/sh busted

Added by Garrett D'Amore almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Start date:
2010-10-21
Due date:
% Done:

100%

Estimated time:
Difficulty:
Tags:

Description

Due to a regression caused by my recent integration of xpg4/sh links. I found that explicit calls to xpg4/bin/sh fail. This was discovered as I was trying a build on my system onu'd with that code. Apparently, /usr/bin/sh is a rotten link target, because, surprise, its not a real program, but isaexec.

We will need a better way to deal with that.

History

#1

Updated by Garrett D'Amore almost 9 years ago

So it turns out that isaexec does the right thing with a symlink instead of a hardlink. So /usr/xpg4/bin/sh needs to be symlinked to /usr/bin/ksh93. See also 362 which will address this as well.

#2

Updated by Garrett D'Amore almost 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed in 13223:ea8e8bad6650

Also available in: Atom PDF