Project

General

Profile

Actions

Bug #3615

closed

chmod: Parser for extended system attributes does not accept '}'

Added by Marcel Telka over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
2013-03-06
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

# /usr/bin/ls -/c a
-rw-r--r--   1 root     root           0 mar  3 04:30 a
                {------------}
# /usr/bin/chmod S=v{archive,hidden} a
chmod: WARNING: can't access S=vhidden
# /usr/bin/ls -/c a
-rw-r--r--   1 root     root           0 mar  3 04:30 a
                {A-----------}
# /usr/bin/chmod S=v{archive,hidden a
# /usr/bin/ls -/c a
-rw-r--r--   1 root     root           0 mar  3 04:30 a
                {AH----------}
#
Actions #1

Updated by Marcel Telka over 9 years ago

  • Status changed from New to Closed

This works:

# /usr/bin/chmod 'S=v{archive,hidden}' a

This is not a bug.

Actions

Also available in: Atom PDF