Project

General

Profile

Actions

Bug #3617

closed

ipf.conf requires a comment on the first line to work

Added by Alasdair Lumsden about 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2013-03-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

As subject. This behaviour is counter-intuitive as people often nuke a file and spew rules into it. Hit it myself, and just helped someone very confused in #smartos who hit the same issue.

This is the chaps SMF log:

http://paste.ec/?31ccac4f46cfeb03#YtsMBbIv24p2bI+RU/tlCr6FjK7+5N7OeUyqTs1QFQs=

Actions #1

Updated by Gary Mills about 8 years ago

  • Status changed from New to Closed
  • Assignee set to Gary Mills

The bug, as reported, does not exist. I've been unable to reproduce it, using valid filter rules either by themself or preceeded by a comment line or an empty line. In all cases, ipf parses them without error. Others have confirmed this observation.

The only way I could cause the error cited was with an ipf.conf that
contained only an empty line, like this:

$ touch /tmp/ipf4.conf
$ /usr/sbin/ipf -n -d -f /tmp/ipf4.conf
$ print $?
0
$ echo "" > /tmp/ipf5.conf
$ /usr/sbin/ipf -n -d -f /tmp/ipf5.conf
syntax error error at "", line 1
$ print $?
1

I'm closing this bug report.

Actions

Also available in: Atom PDF