Project

General

Profile

Actions

Bug #3653

closed

userland ::whatis always complains about "umem_internal_arena" symbol

Added by Christopher Siden about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
mdb - modular debugger
Start date:
2013-03-24
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

with a process target, ::whatis always complains:
mdb: unable to readvar "umem_internal_arena": unknown symbol name

The problem is that mdb_readvar() doesn't find symbols in shared libraries (bug #3651). In addition to fixing that bug, we should use umem_readvar(), which searches only libumem.so.

Actions #1

Updated by Rich Lowe about 8 years ago

  • Status changed from In Progress to Resolved
  • Tags deleted (needs-triage)

Resolved in 22ce014

Actions

Also available in: Atom PDF