Project

General

Profile

Bug #366

pkg is missing version numbers for most packages

Added by Brian Bienvenu over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2010-10-23
Due date:
2011-09-16
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
pkg

Description

When going through the list of packages available (pkg list -a) I noticed that the majority of them have the version tag set as 0.5.11. This isn't very useful as it makes it hard to tell what version the software in the package actually is.

Example:

# pkg list -a | grep xaw
x11/library/toolkit/libxaw4                   0.5.11-0.148    installed  -----
x11/library/toolkit/libxaw5                   0.5.11-0.148    installed  -----
x11/library/toolkit/libxaw7                   1.0.7-0.148     installed  -----

The first two clearly aren't correct, whilst the last one is.

History

#1

Updated by Alan Coopersmith over 9 years ago

"0.5.11" is the shorthand used for "Package built for SunOS 5.11, and we haven't yet figured out a better version number to put here".

In the case of libxaw4 & libxaw5, those are my fault, because I didn't know of any more useful version to put there - those are libraries provided for binary compatibility with software built for older Solaris releases and don't have any upstream version number - they don't exist in that form for any other platform. (They are from Sun's forks of X11R4 & X11R5, in which libraries didn't get separate version numbers from the rest of the window system as we do now in X11R7.)

#2

Updated by Brian Bienvenu over 9 years ago

As discussed in #oi-dev last night, here are some other packages I noticed:

package/rpm                  0.5.11-0.147
web/browser/lynx             0.5.11-0.147
service/hal                  0.5.11-0.148
file/gnu-findutils           0.5.11-0.147
desktop/gftp                 0.5.11-0.147
library/desktop/libglade     0.5.11-0.147
developer/ui-designer/glade  0.5.11-0.147
library/desktop/gtk2         0.5.11-0.147
mail/evolution               0.5.11-0.147
web/editor/bluefish          0.5.11-0.147
desktop/compiz               0.5.11-0.147
image/editor/gimp            0.5.11-0.147

Cheers,

#3

Updated by Ryo Murakawa about 9 years ago

  • Assignee set to OI PKG
#4

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-16
  • Category set to PKG (Image Packaging System)
  • Status changed from New to Closed
  • Target version set to oi_151_stable
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Difficulty set to Bite-size
  • Tags set to pkg

Closed ticket. As Alan mentioned, this is a packaging naming nomenclature brought over from legacy OpenSolaris development. OI package maintainers are either using what the upstream consolidator maintainer used for the build or adjusting their own packages to use version numbers (i.e. Userland/SFE). This is not a bug (it is by legacy design).

Also available in: Atom PDF