Project

General

Profile

Bug #3663

Cheese Webcam Booth - video recording issue

Added by r a over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2013-03-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After upgrading my USB Webcam to a Logitech C310, the device is correctly identified and works with both Ekiga and to a degree with Cheese Webcam Booth, the device is correctly listed as providing 160x120, 320x240, 640x480 and 1280x960 resolutions. While single photo and burst photo mode work correctly there is an issue with video recording as any resolution.

When video mode is selected, the Cheese Webcam Booth screen goes black, the start video recording button can be pressed but only a single image is recorded.

Thinking this was a data rate issue on the USB bus, I added a Belkin Digiconnect 5 Port USB 2.0 PCI card to my system which was correctly identified and the Logitech C310 was plugged into this card. The problem still remains with the video recording, it only appears to record 0.01 seconds of video.

I have used the Belkin Digiconnect USB card for connecting an external HDD and it works perfectly copying around 500GB.

#1

Updated by Ken Mays over 7 years ago

  • Status changed from New to Feedback
  • Assignee set to Milan Jurik
  • % Done changed from 0 to 90

Please test package from the /hipster repo: ,5.11-0.151.1.8:20130407T140345Z

#2

Updated by r a over 7 years ago

Hi,

I switched to the /hipster repo and attempted to upgrade but this failed during the upgrade process when the system kernel was being installed as my computer just rebooted unexpectedly. I then attempted to update my computer again but it failed with the same result.

It would be really useful if there was a program when browsing the repo with Firefox so that when I select the Install link the .p5i file could be installed using a program.

If there is a quick one line command just to install the cheese update I would be happy to try again

#3

Updated by Ken Mays over 7 years ago

  • Assignee changed from Milan Jurik to OI JDS
  • % Done changed from 90 to 0
#4

Updated by r a over 7 years ago

Hi,
On my third attempt I managed to get upgraded to oi151a8_hipster. I have checked the Cheese Webcam booth, when in video mode 160x120 recording does occur smoothly, as I go up the video resolution modes the problems occur. At 320x240 there are refresh lines with the Cheese Webcam window. At 640x480 it is very slow recording. Finally at 1280x960 it appears to record 1 second of video despite running for around a minute.

#5

Updated by Ken Mays over 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Use a clean copy of oi_151a8 (not hipster) release. Set cheese for the soundcard and Xv(imagesink)/GPU. The issue is the cheese default settings uses the CPU for all of the video/sound recording versus offloading to the sound chip/graphic card. If you disable sound, you usually can spot this issue or if you pull both sound/video from the webcam only. Then, adjust your exposure level in cheese after you set your resolution. I notice this is set high by default and with some webcams you have to get enough light for good capture speed. Use Exposure (Absolute).

Also available in: Atom PDF