Project

General

Profile

Bug #367

X hangs when using nvidia drivers

Added by Andrew Chace over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Category:
XNV (X Window System)
Target version:
Start date:
2010-10-22
Due date:
2011-09-14
% Done:

90%

Estimated time:
40.00 h
Difficulty:
Medium
Tags:
needs-triage

Description

When X is configured to use nvidia drivers, it hangs on start-up and the following error message is logged to "Xorg.0.log":

(EE) Apr 25 18:11:48 NVIDIA: WAIT: (E, 0, 0x857d, 0)

This bug is documented here in more detail here:

https://defect.opensolaris.org/bz/show_bug.cgi?id=15751

History

#1

Updated by Albert Lee over 9 years ago

Even though it's apparently not reproducible in Solaris 10 when the same driver versions are used, there's likely not much we can do about this problem until NVIDIA releases a fix.

#2

Updated by Ken Mays over 9 years ago

Requires DMA KVA fix per Oracle's bugster CR 7001754.

#3

Updated by Colin Ellis about 9 years ago

  • Assignee set to Colin Ellis
#4

Updated by Ken Mays almost 9 years ago

  • Status changed from New to Feedback
  • Assignee changed from Colin Ellis to Andrzej Szeszo
  • Target version set to oi_151
  • % Done changed from 0 to 100
  • Difficulty set to Medium
  • Tags set to needs-triage

Resolved with Nvidia 275.09.04 driver update included with oi_151. Please test all affected platforms with oi_151 Live DVD.

#5

Updated by Ian Johnson over 8 years ago

X is still hanging for me with Nvidia driver version 275.21, although intermittently during a window open/close/minimize action rather than immediately upon startup. During constant usage, this happens roughly once an hour. X does not hang if the system is left idle. System configuration:

Sun Microsystems Ultra 24
Nvidia GeForce GT430 1GB
8GB System RAM
OpenIndiana 151

#6

Updated by Ken Mays over 8 years ago

Ian - Update to current oi/dev-il pkg image update. See bugs 1127, & 1135.

#7

Updated by Ian Johnson over 8 years ago

I performed a fresh install of oi_151 and still experience freezes even after short periods of desktop use. Several weeks of use under Solaris 11 Express did not produce this issue, although version 280.13 of the Nvidia driver was being used in both OI and Express.

#8

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-14
  • Status changed from Feedback to In Progress
  • Target version changed from oi_151 to oi_151_stable
  • % Done changed from 100 to 90
  • Estimated time set to 40.00 h

Ian - The fix involves a full pkg image update from the dev-il repo. Can you verify after doing the full pkg update refresh using the dev-il repository?

#9

Updated by Ian Johnson over 8 years ago

Yes, I did a full image-update immediately after installing. When the GUI began freezing, I checked for updates to dev-il before posting and found none.

#10

Updated by Ken Mays over 8 years ago

Issue depends on fix of Bug 1127 (Xnv respin).

#11

Updated by Ken Mays over 8 years ago

  • Status changed from In Progress to Closed

Since we've updated the driver to 280.13, I closing this ticket as a duplicate to 1127 (it is not the driver but X). Please monitor that ticket for resolution.

Also available in: Atom PDF