Project

General

Profile

Actions

Feature #3694

closed

RFE: itadm increase the number of targets to 512 or 1024

Added by Geoff Nordli about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-04-04
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

From the mail list: http://comments.gmane.org/gmane.os.openindiana.general/12243

Thanks Mike La Spina for digging up the code links.

It looks like the itadm utility is limiting the number of targets.

The number of iscsi targets available is 1024.

xref: /illumos-gate/usr/src/uts/common/io/comstar/port/iscsit/iscsit.h 55/* Max targets per system */ 56#define ISCSIT_MAX_TARGETS 1024

itadm is limiting it to 255

http://src.illumos.org/source/xref/illumos-gate/usr/src/lib/libiscsit/common/libiscsit.h

43<http://src.illumos.org/source/xref/illumos-gate/usr/src/lib/libiscsit/common/libiscsit.h#43&gt;#define MAX_TARGETS<http://src.illumos.org/source/s?refs=MAX_TARGETS&project=illumos-gate> 255 /* maximum targets that may be created */

Can this value be increased to 512 or 1024?

thanks,

Geoff


Related issues

Is duplicate of illumos gate - Feature #1437: COMSTAR only supports 255 targetsNew2011-08-31

Actions
Actions #1

Updated by Rich Lowe about 8 years ago

  • Status changed from New to Closed

Duplicate of #1437

Actions

Also available in: Atom PDF