Project

General

Profile

Bug #3707

snmpnetstat broken

Added by Udo Grabowski almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2013-04-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
snmp

Description

snmpnetstat is broken in OI151a7, puts out corrupted lines, a lot of lines
are swallowed (see example below). Same on Osol 2009.06 works correctly, also when copied to OI (with libnetsnmp.so.5).

snmpnetstat -c public -v 2c -i <switch>

Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Queue
Vlan1 1500 19749041 0 41667 0
Vlan5 1500 192.168.2/24 192.168.2.203 11660789 0 1825933 0
Port-channel1 1500 1091532798 0 2384525987 0
Port-channel2 1500 14857212 0 19223331 0
Port-channel3 1500 61733794 0 74039216 0
Port-channel4 1500 2328660554 0 207569041 0
<�J� 1500 452004959 0 334881868 0
Port-channel11 1500 328402311 0 465405714 0
GigabitEthernet0/1 1500 570749997 0 22611270 0
GigabitEthernet0/2 1500 591452756 0 13233581 0
GigabitEthernet0/3 1500 1894942521 0 604022512 0
GigabitEthernet0/4 1500 656153899 0 64945515 0
GigabitEthernet0/5 1500 180340751 0 324844542 0
GigabitEthernet0/6 1500 384992433 0 305383153 0
GigabitEthernet0/7 1500 0 0 255 0
GigabitEthernet0/8 1500 0 0 14379155 0
GigabitEthernet0/9 1500 0 0 8602 0
GigabitEthernet0/10 1500 0 0 0 0
W8� 1500 19744999 0 47730143 0
] 1500 240930851 0 40871662 0
�D 1500 87554645 0 424681085 0
GigabitEthernet0/18 1500 20195 0 4682510 0
GigabitEthernet0/25 1500 118910 0 4226708 0
1500 92649 0 4166449 0
GigabitEthernet0/27 1500 0 0 0 0
GigabitEthernet0/28 1 0 0 0 0


Related issues

Related to OpenIndiana Distribution - Bug #4190: Update to Net-SNMP 5.4.1.2Resolved2013-10-082013-10-31

Actions

History

#1

Updated by Ken Mays over 6 years ago

  • Status changed from New to Feedback
  • Assignee set to OI Userland
  • % Done changed from 0 to 90

Please test this package from the /hipster repo: ,5.11-0.151.1.8:20130305T141625Z

#2

Updated by Udo Grabowski over 6 years ago

Issue is not solved with OI/hipster oi_151a8, same broken behaviour.

#3

Updated by Ken Mays over 6 years ago

  • % Done changed from 90 to 0
#4

Updated by Udo Grabowski over 6 years ago

How can I do that without installing a complete Solaris 11 system ?

#5

Updated by Udo Grabowski over 6 years ago

No way found to test this, solaris 11 (tested live DVD) does not support our
network cards (skge) nor its old gldv2 driver which we need to get access to
the separated service net where those switches are located which deliver the
snmp answers needed to test the snmpnetstat command.

#6

Updated by Ken Mays over 6 years ago

  • Category set to 10
  • Tags changed from needs-triage to snmp

Udo,
Test in oi_151a8:
,5.11-0.151.1.8:20130721T124543Z

I'm going to suggest a rebuild to the oi-userand maintainers.

#7

Updated by Ken Mays over 6 years ago

  • Status changed from Feedback to Closed

Resolved dependency and tested issue with newer net-snmp packages (2013.10.x) in /hipster repo. Will pin for a9 release.

Also available in: Atom PDF