Project

General

Profile

Bug #372

console-kit-daemon errors during boot

Added by Petri Kunnari almost 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2010-10-24
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

console-kit-daemon631: [ID 702911 daemon.crit] CRITICAL: file dbus-gproxy.c: line 2084: assertion `DBUS_IS_G_PROXY (proxy)' failed

console-kit-daemon631: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat"

console-kit-daemon631: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat"

console-kit-daemon631: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction

Using illumos-gate revision 13226

History

#1

Updated by Petri Kunnari almost 9 years ago

Please assing/relocate this to openindiana...

#2

Updated by Albert Lee almost 9 years ago

  • Project changed from illumos gate to OpenIndiana Distribution
#3

Updated by Albert Lee almost 9 years ago

  • Category set to Desktop (JDS)
  • Priority changed from Normal to Low

Only the warnings are reproducible in oi_147:

Oct 30 11:33:35 ichiban console-kit-daemon[340]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Oct 30 11:33:35 ichiban console-kit-daemon[340]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 

#4

Updated by Julian Wiesener over 8 years ago

  • Status changed from New to Closed
  • Target version set to oi_151
  • Difficulty set to Medium
  • Tags set to needs-triage

since i cannot reproduce eben the warning using oi_illumos (consolekit online) and the bug was not reported against any oi release

#5

Updated by Richard PALO over 7 years ago

  • Status changed from Closed to Feedback

I'm getting the following trying to VNC into a oi_151a2 server :
(first the last part of booting up after upgrading last evening, then just now issuing a vncviewer <server>...

Mar  2 19:01:56 smicro console-kit-daemon[1833]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction
Mar  2 19:01:56 smicro gdm-simple-slave[3507]: [ID 702911 daemon.warning] WARNING: GdmWelcomeSession: Error setting owner of run time directory: No such file or directory
Mar  2 19:01:56 smicro gdm-simple-slave[3512]: [ID 702911 daemon.warning] WARNING: GdmWelcomeSession: Error setting owner of run time directory: No such file or directory
Mar  2 19:01:57 smicro gnome-session[3512]: [ID 702911 daemon.warning] WARNING: IceListenForConnections returned 2 non-local listeners: inet/smicro:39705,inet6/smicro:59863
Mar  2 19:01:58 smicro gnome-session[3512]: [ID 702911 daemon.warning] atk-bridge-WARNING: AT_SPI_REGISTRY was not started at session startup.
Mar  2 19:01:58 smicro gnome-session[3512]: [ID 702911 daemon.warning] atk-bridge-WARNING: IOR not set.
Mar  2 19:01:58 smicro gnome-session[3512]: [ID 702911 daemon.warning] atk-bridge-WARNING: Could not locate registry
Mar  2 19:02:00 smicro pseudo: [ID 129642 kern.info] pseudo-device: pm0
Mar  2 19:02:00 smicro genunix: [ID 936769 kern.info] pm0 is /pseudo/pm@0
Mar  2 19:02:01 smicro syslog[3542]: [ID 702911 daemon.warning] Gtk-WARNING: gtkwidget.c:5628: widget not within a GtkWindow
Mar  2 20:29:18 smicro gdm-binary[3492]: [ID 702911 daemon.warning] WARNING: Unable to lookup hostname: node name or service name not known
Mar  2 20:29:18 smicro gdm-binary[3492]: [ID 702911 daemon.warning] WARNING: Unable to lookup numeric info: node name or service name not known
Mar  2 20:29:18 smicro last message repeated 1 time
Mar  2 20:29:18 smicro gdm-binary[3492]: [ID 702911 daemon.warning] WARNING: Unable to lookup hostname: node name or service name not known
Mar  2 20:29:18 smicro gdm-binary[3492]: [ID 702911 daemon.warning] WARNING: Unable to lookup numeric info: node name or service name not known
Mar  2 20:29:18 smicro last message repeated 1 time
Mar  3 12:45:19 smicro console-kit-daemon[1833]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Mar  3 12:45:19 smicro console-kit-daemon[1833]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 
Mar  3 12:45:19 smicro gdm-simple-slave[20591]: [ID 702911 daemon.warning] WARNING: GdmWelcomeSession: Error setting owner of run time directory: No such file or directory
Mar  3 12:45:19 smicro gdm-simple-slave[20596]: [ID 702911 daemon.warning] WARNING: GdmWelcomeSession: Error setting owner of run time directory: No such file or directory
Mar  3 12:45:19 smicro gnome-session[20596]: [ID 702911 daemon.warning] WARNING: IceListenForConnections returned 2 non-local listeners: inet/smicro:48240,inet6/smicro:58975
Mar  3 12:45:21 smicro syslog[20618]: [ID 702911 daemon.warning] Gtk-WARNING: gtkwidget.c:5628: widget not within a GtkWindow
Mar  3 12:45:47 smicro syslog[20618]: [ID 702911 daemon.warning] WARNING: Failed to send buffer
Mar  3 12:45:57 smicro gdm-simple-slave[20584]: [ID 702911 daemon.crit] CRITICAL: file gdm-session-direct.c: line 2167: assertion `value != NULL' failed
Mar  3 12:45:58 smicro gnome-session[20631]: [ID 702911 daemon.warning] WARNING: IceListenForConnections returned 2 non-local listeners: inet/smicro:50605,inet6/smicro:59419
Mar  3 12:47:45 smicro console-kit-daemon[1833]: [ID 702911 daemon.crit] GLib-GObject-CRITICAL: file gobject.c: line 2396: assertion `G_IS_OBJECT (object)' failed

#6

Updated by Ken Mays over 6 years ago

  • Assignee set to Milan Jurik
#7

Updated by Ken Mays about 6 years ago

  • Assignee changed from Milan Jurik to OI JDS
#8

Updated by Ken Mays about 6 years ago

  • Status changed from Feedback to Closed
  • Target version deleted (oi_151)
  • % Done changed from 0 to 100

Tested in oi_151a8. No errors during boot regarding this ticket. Closing ticket.

#9

Updated by Richard PALO about 6 years ago

Ken Mays wrote:

Tested in oi_151a8. No errors during boot regarding this ticket. Closing ticket.

You have a magic system, then. I still get the following:

richard@x3200:~$ grep console\\-kit /var/adm/messages
Aug 12 08:58:36 x3200 console-kit-daemon[511]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Aug 12 08:58:36 x3200 console-kit-daemon[511]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 
Aug 12 08:58:41 x3200 console-kit-daemon[511]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction
Aug 12 18:49:32 x3200 console-kit-daemon[547]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Aug 12 18:49:32 x3200 console-kit-daemon[547]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 
Aug 12 18:49:37 x3200 console-kit-daemon[547]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction
Aug 13 21:35:52 x3200 console-kit-daemon[516]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Aug 13 21:35:52 x3200 console-kit-daemon[516]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 
Aug 13 21:35:59 x3200 console-kit-daemon[516]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction
Aug 13 22:24:31 x3200 console-kit-daemon[516]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction
Aug 14 06:38:33 x3200 console-kit-daemon[553]: [ID 702911 daemon.warning] WARNING: signal "open_session_request" (from "OpenSessionRequest") exported but not found in object class "CkSeat" 
Aug 14 06:38:33 x3200 console-kit-daemon[553]: [ID 702911 daemon.warning] WARNING: signal "close_session_request" (from "CloseSessionRequest") exported but not found in object class "CkSeat" 
Aug 14 06:38:38 x3200 console-kit-daemon[553]: [ID 702911 daemon.warning] GLib-GObject-WARNING: g_object_set_property: construct property "seat-id" for object `CkSession' can't be set after construction

==== added 31/12/2015 ====
extremely magic, as I still get this with oi-hipster 2015 illumos-043552b

#10

Updated by Richard PALO over 3 years ago

suprisingly, this should already be fixed: https://bugs.freedesktop.org/show_bug.cgi?id=19333#c19
which seems to be in the solaris-desktop-spec-files patchsets for ConsoleKit.
Is it possible that the OI patches not up to date?

Also available in: Atom PDF