Project

General

Profile

Bug #3727

british people can't spell

Added by Rich Lowe almost 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-04-18
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

If you try to use spell -b, it segvs behind the scenes and acts as if everything is correct. I'm guessing constant string crap.

> echo "foo" | spell -b
> ls -lt /var/cores/*spell*
-rw------- 1 root root 2158470 2013-04-19 17:47 /var/cores/101.spellprog.17067-1366408068
> pstack /var/cores/101.spellprog.17067-1366408068
 08051611 ztos     (fef73000, feffb0a4, 8047ab0, 8047b74, 8047ac0, fefc3330) + f
 08051ff0 main     (805293a, feffb0a4, 8047ae8, 8051483, 4, 8047af4) + 51
 08051483 _start   (4, 8047be4, 8047bfd, 8047c00, 8047c16, 0) + 83
#1

Updated by Gary Mills over 5 years ago

You were right. The 0C4 is caused by an attempt to write to a static string. I'm looking for a fix.

#2

Updated by Electric Monk over 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 17723245e5b42ca8abb9964a36c0b051c0b237fe

commit  17723245e5b42ca8abb9964a36c0b051c0b237fe
Author: Gary Mills <gary_mills@fastmail.fm>
Date:   2015-06-17T15:42:43.000Z

    3727 british people can't spell
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom PDF