Project

General

Profile

Actions

Feature #3756

closed

want lz4 support for metadata compression

Added by Martin Matuška over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
2013-05-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Metadata on ZFS is compressed using the lzjb algorithm by default.
The advantages of lz4 compression may be used in this area, too.

There are more ways this can be done:

  • a global tunable, this requires no changes to current features layout
  • a new pool or dataset property for metadata compression

Related issues

Is duplicate of illumos gate - Feature #4924: LZ4 Compression for metadataClosedDaniil Lunev2014-06-13

Actions
Actions #1

Updated by Prasad Joshi about 8 years ago

  • Assignee set to Prasad Joshi
Actions #2

Updated by Marcel Telka over 7 years ago

  • Status changed from New to Closed

Duplicate of #4924.

Actions

Also available in: Atom PDF