Project

General

Profile

Bug #380

SPARC: n2rng requires fips header removed in 294b1fe4bc7f

Added by Jon Tibble almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2010-10-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

When $SRC/common/crypto/fips/* was removed as part of the open kcfd changeset (294b1fe4bc7f) it broke n2rng which required the fips_checksum.h header.

Excerpt from nightly.log:

+ /usr/sfw/bin/gcc -fident -finline -fno-inline-functions -fno-builtin -fno-asm
-nodefaultlibs -mno-integer-ldd-std -D__sun -mtune=ultrasparc -fno-pic -mcmodel=
medlow -m64 -mcpu=ultrasparc -mvis -fno-strict-aliasing -fno-unit-at-a-time -fno
-optimize-sibling-calls -O2 -D_ASM_INLINES -Wall -Wno-unknown-pragmas -Wno-missi
ng-braces -Wno-sign-compare -Wno-parentheses -Wno-uninitialized -Wno-implicit-function-declaration -Wno-unused -Wno-trigraphs -Wno-char-subscripts -Wno-switch -Werror -gdwarf-2 -std=gnu99 -fno-dwarf2-indirect-strings -std=gnu99 -mno-fpu -DN2 -I../../../common/crypto -D_KERNEL -ffreestanding -D_SYSCALL32 -D_SYSCALL32_IMPL -D_ELF64 -D_DDI_STRICT -Dsun -D__sun -D__SVR4 -Dsun4v -D_MACHDEP -DSFMMU -DMAX_MEM_NODES=8 -DQCN_POLLING -DDO_CORELEVEL_LOADBAL -DDEBUG -I../../sun4 -I../../sun4v -I../../sfmmu -I../../sparc/v9 -I../../sparc -I../../sparc/krtld -I../../sun -nostdinc -I../../common -DGLREG -c -o /tmp/nightly.tmpdir.10251/.cwCAAnXaOcT.o ../../sun4v/io/n2rng/n2rng.c
../../sun4v/io/n2rng/n2rng.c:50:32: fips/fips_checksum.h: No such file or directory
+ /opt/SUNWspro/bin/cc -xchip=ultra -Wc,-xcode=abs32 -Wc,-Qiselect-regsym=0 -m64 -xarch=sparcvis -xO3 ../../sparc/ml/sparc.il -D_ASM_INLINES -Xa -xspace -W0,-Lt -errtags=yes -errwarn=%all -g -Wc,-Qiselect-T1 -xc99=%all -W0,-noglobal -xdebugformat=stabs -xc99=%all -Wd,-xsafe=unboundsym -Wc,-Qassembler-ounrefsym=0 -W2,-xwrap_int -W0,-xglobalstatic -xregs=no%float -xstrconst -v -DN2 -I../../../common/crypto -D_KERNEL -D_SYSCALL32 -D_SYSCALL32_IMPL -D_ELF64 -D_DDI_STRICT -Dsun -D__sun -D__SVR4 -Dsun4v -D_MACHDEP -DSFMMU -DMAX_MEM_NODES=8 -DQCN_POLLING -DDO_CORELEVEL_LOADBAL -DDEBUG -I../../sun4 -I../../sun4v -I../../sfmmu -I../../sparc/v9 -I../../sparc -I../../sparc/krtld -I../../sun -Y I,../../common -DGLREG -c -o debug64/n2rng.o ../../sun4v/io/n2rng/n2rng.c
"../../sun4v/io/n2rng/n2rng.c", line 50: cannot find include file: <fips/fips_checksum.h>
"../../sun4v/io/n2rng/n2rng.c", line 1097: warning: implicit function declaration: fips_check_module (E_NO_IMPLICIT_DECL_ALLOWED)
cc: acomp failed for ../../sun4v/io/n2rng/n2rng.c
  • Error code 3
    dmake: Warning: Command failed for target `debug64/n2rng.o'
    Current working directory /export/home/jt/BUILD_ILLUMOS/ILLUMOS/illumos/usr/src/uts/sun4v/n2rng

Related issues

Is duplicate of illumos gate - Bug #297: SPARC build fails possibly due to 'Need open kcfd' changesClosed2010-10-04

Actions

History

#1

Updated by Albert Lee almost 9 years ago

  • Status changed from New to Closed

Closing duplicate.

Also available in: Atom PDF