Project

General

Profile

Support #3803

Compile error

Added by Fred von Stein over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-06-06
Due date:
% Done:

0%

Estimated time:
Tags:
needs-triage

Description

Hi,
I am running OmniOS (latest stable) on an HP micro server, which uses an AMD Turion II cpu, trying to build libassuan, a library necessary for GnuPG. When I go to make libassuan, I end with an error:

In file included from /usr/include/sys/regset.h:420:0,
from /usr/include/sys/ucontext.h:36,
from /usr/include/sys/signal.h:245,
from /usr/include/sys/procset.h:42,
from /usr/include/sys/wait.h:43,
from /usr/include/stdlib.h:38,
from assuan.c:26:
/usr/include/amd64/sys/privregs.h:42:2: error: #error "non-amd64 code depends on amd64 privileged header!"
make2: * [libassuan_la-assuan.lo] Error 1
make2: Leaving directory `/root/libassuan-2.1.0/src'
make1:
[check] Error 2
make1: Leaving directory `/root/libassuan-2.1.0/src'
make: *
* [check-recursive] Error 1

Contents of /usr/include/amd64/sys/privregs.h :
36 /*
37 * This file describes the cpu's privileged register set, and
38 * how the machine state is saved on the stack when a trap occurs.
39 */
40
41 #if !defined(__amd64)
42 #error "non-amd64 code depends on amd64 privileged header!"
43 #endif

Searching google for this string indicates it is part of the illumos distro.
I found a few pastebin examples of someone with this same error trying to compile Mediatomb, but no other references.

Can anyone explain to me what this error is, and how I can work it out?

History

#1

Updated by Rich Lowe about 6 years ago

  • Project changed from site to illumos gate
#2

Updated by Yuri Pankov about 6 years ago

  • Status changed from New to Closed

Not a bug/feature, please use mailing lists.

Also available in: Atom PDF