Project

General

Profile

Bug #3815

AHCI: Support for Marvell 88SE9128

Added by Marcel Telka over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
driver - device drivers
Start date:
2013-06-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

The Marvell 88SE9128 AHCI Controller was suffering by the same bug as ASMedia ASM1062, i.e. 64-bit writes to PxCLB, PxCLBU, PxFB, and PxFBU failed - see Bug #3797. After the fix the 88SE9128 started to work somehow, but unreliably. Sometime the attached disks were detected, but usually not.

In general, the port reset (in function ahci_port_reset) is failing.

The problem is that the ahci_port_reset() does not follow the port reset sequence as documented in the AHCI spec, section 10.4.2.


Related issues

Related to illumos gate - Bug #3797: AHCI: Support for ASMedia ASM106xResolved2013-05-29

Actions
Related to illumos gate - Feature #4904: Add support for Marvell 88SE9130New2014-06-02

Actions
Has duplicate illumos gate - Bug #993: Marvell SATA controller 88SE9128 - driver issue?Closed2011-05-052011-09-14

Actions
Has duplicate illumos gate - Bug #3099: AMD hudson D3 AHCI supportClosed2012-08-20

Actions

History

#1

Updated by Marcel Telka over 6 years ago

There are few other issues with 88SE9128:

#2

Updated by Marcel Telka about 6 years ago

  • Status changed from In Progress to Pending RTI
#3

Updated by Robert Mustacchi about 6 years ago

  • Status changed from Pending RTI to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Resolved in b476795742d7abfe9d77f4914d015bb0b17f747e.

Also available in: Atom PDF