Project

General

Profile

Bug #3830

SIGQUEUE_MAX's limit of 32 is too low

Added by Cedric Blancher over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2013-06-18
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

Taken from the list:

On 18 June 2013 19:33, Gary Mills <gary_mills@fastmail.fm> wrote:
> On Tue, Jun 18, 2013 at 07:01:08PM +0200, Cedric Blancher wrote:
>> ksh93 -c 'getconf SIGQUEUE_MAX' returns 32 on Illumos but 5632 on Suse
>> 12.3 Linux. Does anyone know why the values are so... different?
>
> $ uname -a
> SunOS qtpie 5.11 11.1 i86pc i386 i86pc
> $ whence getconf
> /usr/bin/getconf
> $ getconf SIGQUEUE_MAX
> 128

This is still far too low if you wish to use realtime signals for
inter-process communication. It defeats the purpose of
SIGRTMIN-SIGRTMAX which are supposed to be *reliable*.

The issue is that the SIGQUEUE_MAX limit in Illumos is far to low to be usable. Solaris 11.1 uses 128 and Linux uses 5632.

IMO a limit of at least 32*32, i.e. 1024 would be the minimum acceptable for any application which wishes to use realtime signals (i.e. SIGRTMIN-SIGRTMAX) for reliable and fast interprocess/interthread communication.

AFAIK bumping this limite was forgotten when SUN increased the realtime signals from 8 signals (a joke these days) to 64^H^H32.

History

#1

Updated by David Höppner about 6 years ago

Found no advocate for this patch. Archive it here.
http://cr.illumos.org/~webrev/0xffea/rctl-sigqueue-05/

#2

Updated by Rich Lowe about 6 years ago

  • Category set to kernel
  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Resolved in 5e989a9

Also available in: Atom PDF