Project

General

Profile

Feature #3859

GLwCreateMDrawingArea is missing from libGLw

Added by Johann Oskarsson about 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2013-07-01
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The symbol GLwCreateMDrawingArea is not defined in /usr/lib/libGLw.so.1.

It is defined in the header /usr/include/GL/GLwMDrawA.h which is in pkg: but the corresponding symbol is undefined in the shared library.

Attached is a program that should compile with -lGLw but doesn't (afaik).


Files

create_m_drawing_area.c (301 Bytes) create_m_drawing_area.c Johann Oskarsson, 2013-07-01 11:36 PM
Mesa_7.4.4_Makefile (2.19 KB) Mesa_7.4.4_Makefile Ken Mays, 2015-01-29 03:11 PM

History

#1

Updated by Johann Oskarsson about 7 years ago

gcc -o create_m_drawing_area create_m_drawing_area.o -lGLw -lXt
Undefined                       first referenced
 symbol                             in file
GLwCreateMDrawingArea               create_m_drawing_area.o
ld: fatal: symbol referencing errors. No output written to create_m_drawing_area
collect2: ld returned 1 exit status
#2

Updated by Ken Mays about 7 years ago

As discussed, you'd have to rebuild libGLw with motif feature enabled (disabled by default). Not really a bug.

#3

Updated by Ken Mays about 7 years ago

  • Assignee set to OI XNV
#4

Updated by Ken Mays about 7 years ago

  • Status changed from New to Closed

Johann - Closing this ticket as it is not a bug nor part of the core distro, but a feature request.

#5

Updated by Jon Tibble about 7 years ago

  • Tracker changed from Bug to Feature

Changed to Feature.

#6

Updated by Jon Tibble about 7 years ago

  • Status changed from Closed to New
#7

Updated by Ken Mays over 5 years ago

  • Status changed from New to Closed
  • Assignee changed from OI XNV to Ken Mays
  • % Done changed from 0 to 100

Fixed. Patch submitted for hipster-2015/oi-151a9|10.
http://pkg.openindiana.org/hipster-2015
,5.11-2015.0.0.0:20150206T062316Z
,5.11-2015.0.0.0:20150206T091828Z
,5.11-2015.0.0.0:20150206T091829Z

Also available in: Atom PDF