Project

General

Profile

Actions

Bug #3883

closed

gnome-terminal segfault when minimizing

Added by Udo Grabowski about 8 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-07-12
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Hi,
OI_151a8.1 hipster:
open a simple gnome-terminal, grab the upper border, and make
window smaller vertically down to a few lines and then larger again.
After that, window stalls, and 20 sec later all gnome-terminal windows
crash.

Starting from an xterm, I can dbx it and see a segmentation fault
in the slider code:

(gnome-terminal:18295): Gtk-CRITICAL **: file gtkwidget.c: line 5750: assertion
`GTK_IS_WIDGET (widget)' failed
Segmentation fault

and, sometimes, it also kills the gnome-settings-daemon (window pixmaps vanish)

ug1(~) dbx /usr/bin/gnome-terminal
Reading gnome-terminal
Reading ld.so.1
Reading libc.so.1
Reading libgobject-2.0.so.0.2800.6
Reading libglib-2.0.so.0.2800.6
(dbx) run
Running: gnome-terminal
(process id 18680)
Reading libgthread-2.0.so.0.2800.6
Reading libpthread.so.1
Reading libgtk-x11-2.0.so.0.2000.1
Reading libgdk-x11-2.0.so.0.2000.1
Reading libcairo.so.2.11000.2
Reading libXrender.so.1
Reading libX11.so.4
Reading libXext.so.0
Reading libgio-2.0.so.0.2800.6
Reading libresolv.so.2
Reading libnsl.so.1
Reading libsocket.so.1
Reading xlcUTF8Load.so.2
Reading libXau.so.6
Reading libXrandr.so.2
Reading libXfixes.so.1
Reading libXcomposite.so.1
Reading libXdamage.so.1
Reading libXi.so.5
Reading libpango-1.0.so.0.2800.3
Reading libgmodule-2.0.so.0.2800.6
Reading libnimbus.so
Reading libgdk_pixbuf-2.0.so.0.2000.1
Reading libXcursor.so.1
Reading libcanberra-gtk-module.so
Reading libatk-1.0.so.0.3009.1
Reading libICE.so.6
Reading libSM.so.6
Reading libdbus-glib-1.so.2.1.0
Reading libdbus-1.so.3.4.3
Reading librt.so.1
Reading libgconf-2.so.4.1.5
Reading libORBit-2.so.0.1.0
Reading libvte.so.9.2600.2
Reading UTF-8%8859-15.so
Reading UTF-8%UTF-8.so
Reading libpangocairo-1.0.so.0.2800.3
Reading libpangoft2-1.0.so.0.2800.3
Reading libfontconfig.so.1
Reading libfreetype.so.6
Reading libm.so.2
Reading libexpat.so.1.6.0
Reading pango-basic-fc.so
Reading libgioremote-volume-monitor.so
Reading libgsettingsgconfbackend.so
Reading libgvfsdbus.so
Reading libgvfscommon.so.0.0.0
Reading libgiogconf.so
Reading libmlib.so.2
Reading libmlib_sse2.so.2
Reading im-xim.so
Reading xiiimp.so.2
Reading libiiimcf.so.3.0.0
Reading libiiimp.so.1.0.0
Reading ximcp.so.2
Reading libpixman-1.so.0
Reading xomGeneric.so.2

(gnome-terminal:18680): Gtk-CRITICAL **: file gtkwidget.c: line 5750: assertion
`GTK_IS_WIDGET (widget)' failed
t@1 (l@1) signal SEGV (no mapping at the fault address) in from_mozilla_widget
at 0xfdfd7e71
0xfdfd7e71: from_mozilla_widget+0x003d: cmpb %al,(%ecx)
(dbx) where
current thread: t@1
=>[1] from_mozilla_widget(0x82140a0, 0x0, 0x1, 0x0), at 0xfdfd7e71
[2] draw_slider(0x824ce58, 0x80e09f8, 0x0, 0x2, 0x8045100, 0x82140a0,
0xfe7d2e0c, 0x193, 0x2a, 0xd, 0x1, 0x1), at 0xfdfdcc7d
[3] gtk_paint_slider(0x824ce58, 0x80e09f8, 0x0, 0x2, 0x8045100, 0x82140a0,
0xfe7d2e0c, 0x193, 0x2a, 0xd, 0x1, 0x1), at 0xfe61cbe6
[4] gtk_range_expose(0x82140a0, 0x8244e80), at 0xfe5d52fe
[5] gtk_marshal_BOOLEAN_BOXED(0x810dc40, 0x80452c0, 0x2, 0x823f8a0,
0x80452e8, 0xfe5d4bc8, 0x80451e8, 0xfedd295c), at 0xfe592fc4
[6] g_type_class_meta_marshal(0x810dc40, 0x80452c0, 0x2, 0x823f8a0,
0x80452e8, 0xc8, 0x40008006, 0xfedd25ce), at 0xfedd2996
[7] g_closure_invoke(0x810dc40, 0x80452c0, 0x2, 0x823f8a0, 0x80452e8,
0x82140a0, 0x8045268, 0xfede90e9), at 0xfedd267a
[8] signal_emit_unlocked_R(0x810db38, 0x0, 0x82140a0, 0x8045400, 0x823f8a0,
0x14, 0x80453c0, 0x8000000), at 0xfedea1f5
[9] g_signal_emit_valist(0x82140a0, 0x29, 0x0, 0x80454ac), at 0xfede8bb1
[10] g_signal_emit(0x82140a0, 0x29, 0x0, 0x8244e80, 0x80454cc, 0xfee10e2c,
0x80454e8, 0xfe6beea6), at 0xfede8f25
[11] gtk_widget_event_internal(0x82140a0, 0x8244e80, 0x8045508, 0xfe6bec78),
at 0xfe6bf09c
[12] gtk_widget_send_expose(0x82140a0, 0x8244e80, 0x8045548, 0xfe511536), at
0xfe6becf9
[13] gtk_container_propagate_expose(0x8140108, 0x82140a0, 0x8244ed0,
0xfe5112e4), at 0xfe511663
[14] gtk_container_expose_child(0x82140a0, 0x80455e8, 0x80455a8, 0xfe4dc872),
at 0xfe5112fe
[15] gtk_box_forall(0x8140108, 0x1, 0xfe5112d8, 0x80455e8), at 0xfe4dc8a5
[16] gtk_container_forall(0x8140108, 0xfe5112d8, 0x80455e8, 0xfe511322), at
0xfe50f7f4
[17] gtk_container_expose(0x8140108, 0x8244ed0), at 0xfe51136c
[18] gtk_marshal_BOOLEAN_BOXED(0x810dc40, 0x80457a0, 0x2, 0x823f828,
0x80457c8, 0xfe511308, 0x80456c8, 0xfedd295c), at 0xfe592fc4
[19] g_type_class_meta_marshal(0x810dc40, 0x80457a0, 0x2, 0x823f828,
0x80457c8, 0xc8, 0x40008005, 0xfedd25ce), at 0xfedd2996
[20] g_closure_invoke(0x810dc40, 0x80457a0, 0x2, 0x823f828, 0x80457c8,
0xfee11630, 0x80457e0, 0x0), at 0xfedd267a
[21] signal_emit_unlocked_R(0x810db38, 0x0, 0x8140108, 0x80458e0, 0x823f828,
0x14, 0x80458a0, 0x8000000), at 0xfedea1f5
[22] g_signal_emit_valist(0x8140108, 0x29, 0x0, 0x804598c), at 0xfede8bb1
[23] g_signal_emit(0x8140108, 0x29, 0x0, 0x8244ed0, 0x80459ac, 0xfee10e2c,
0x80459c8, 0xfe6beea6), at 0xfede8f25
[24] gtk_widget_event_internal(0x8140108, 0x8244ed0, 0x80459e8, 0xfe6bec78),
at 0xfe6bf09c
[25] gtk_widget_send_expose(0x8140108, 0x8244ed0, 0x8045a28, 0xfe511536), at
0xfe6becf9
[26] gtk_container_propagate_expose(0x8140860, 0x8140108, 0x8244f20,
0xfe5b0496), at 0xfe511663
[27] gtk_notebook_expose(0x8140860, 0x8244f20), at 0xfe5b0576
[28] gtk_marshal_BOOLEAN_BOXED(0x810dc40, 0x8045c10, 0x2, 0x823f4c8,
0x8045c38, 0xfe5b047c, 0x8045b38, 0xfedd295c), at 0xfe592fc4
[29] g_type_class_meta_marshal(0x810dc40, 0x8045c10, 0x2, 0x823f4c8,
0x8045c38, 0xc8, 0x40008004, 0xfedd25ce), at 0xfedd2996
[30] g_closure_invoke(0x810dc40, 0x8045c10, 0x2, 0x823f4c8, 0x8045c38,
0xfee11630, 0x8045c50, 0x0), at 0xfedd267a
[31] signal_emit_unlocked_R(0x810db38, 0x0, 0x8140860, 0x8045d50, 0x823f4c8,
0x14, 0x8045d10, 0x8000000), at 0xfedea1f5
[32] g_signal_emit_valist(0x8140860, 0x29, 0x0, 0x8045dfc), at 0xfede8bb1
[33] g_signal_emit(0x8140860, 0x29, 0x0, 0x8244f20, 0x8045e1c, 0xfee10e2c,
0x8045e38, 0xfe6beea6), at 0xfede8f25
[34] gtk_widget_event_internal(0x8140860, 0x8244f20, 0x8045e58, 0xfe6bec78),
at 0xfe6bf09c
[35] gtk_widget_send_expose(0x8140860, 0x8244f20, 0x8045e98, 0xfe511536), at
0xfe6becf9
[36] gtk_container_propagate_expose(0x8140000, 0x8140860, 0x80dff78,
0xfe5112e4), at 0xfe511663
[37] gtk_container_expose_child(0x8140860, 0x8045f38, 0x8045ef8, 0xfe4dc872),
at 0xfe5112fe
[38] gtk_box_forall(0x8140000, 0x1, 0xfe5112d8, 0x8045f38), at 0xfe4dc8df
[39] gtk_container_forall(0x8140000, 0xfe5112d8, 0x8045f38, 0xfe511322), at
0xfe50f7f4
[40] gtk_container_expose(0x8140000, 0x80dff78), at 0xfe51136c
[41] gtk_marshal_BOOLEAN_BOXED(0x810dc40, 0x80460f0, 0x2, 0x823f850,
0x8046118, 0xfe511308, 0x8046018, 0xfedd295c), at 0xfe592fc4
[42] g_type_class_meta_marshal(0x810dc40, 0x80460f0, 0x2, 0x823f850,
0x8046118, 0xc8, 0x40008003, 0xfedd25ce), at 0xfedd2996
[43] g_closure_invoke(0x810dc40, 0x80460f0, 0x2, 0x823f850, 0x8046118,
0x8140000, 0x8046098, 0xfede90e9), at 0xfedd267a
[44] signal_emit_unlocked_R(0x810db38, 0x0, 0x8140000, 0x8046230, 0x823f850,
0x14, 0x80461f0, 0x8000000), at 0xfedea1f5
[45] g_signal_emit_valist(0x8140000, 0x29, 0x0, 0x80462dc), at 0xfede8bb1
[46] g_signal_emit(0x8140000, 0x29, 0x0, 0x80dff78, 0x80462fc, 0xfee10e2c,
0x8046318, 0xfe6beea6), at 0xfede8f25
[47] gtk_widget_event_internal(0x8140000, 0x80dff78, 0x8046338, 0xfe6bec78),
at 0xfe6bf09c
[48] gtk_widget_send_expose(0x8140000, 0x80dff78, 0x8046378, 0xfe511536), at
0xfe6becf9
[49] gtk_container_propagate_expose(0x813d080, 0x8140000, 0x80468b0,
0xfe5112e4), at 0xfe511663
[50] gtk_container_expose_child(0x8140000, 0x80463f8, 0x80463b8, 0xfedf2e9c),
at 0xfe5112fe
[51] gtk_bin_forall(0x813d080, 0x1, 0xfe5112d8, 0x80463f8), at 0xfe4d8182
[52] gtk_container_forall(0x813d080, 0xfe5112d8, 0x80463f8, 0xfe511322), at
0xfe50f7f4
[53] gtk_container_expose(0x813d080, 0x80468b0, 0x8046468, 0xfe6d260c), at
0xfe51136c
[54] gtk_window_expose(0x813d080, 0x80468b0), at 0xfe6d2659
[55] gtk_marshal_BOOLEAN_BOXED(0x810dc40, 0x80465d0, 0x2, 0x825b450,
0x80465f8, 0xfe6d2600, 0x80464f8, 0xfedd295c), at 0xfe592fc4
[56] g_type_class_meta_marshal(0x810dc40, 0x80465d0, 0x2, 0x825b450,
0x80465f8, 0xc8), at 0xfedd2996
[57] g_closure_invoke(0x810dc40, 0x80465d0, 0x2, 0x825b450, 0x80465f8,
0xfee11630, 0x8046610, 0x0), at 0xfedd26a1
[58] signal_emit_unlocked_R(0x810db38, 0x0, 0x813d080, 0x8046710, 0x825b450,
0x14, 0x80466d0, 0x8000000), at 0xfedea1f5
[59] g_signal_emit_valist(0x813d080, 0x29, 0x0, 0x80467bc), at 0xfede8bb1
[60] g_signal_emit(0x813d080, 0x29, 0x0, 0x80468b0, 0x80467dc, 0xfee10e2c,
0x80467f8, 0xfe6beea6), at 0xfede8f25
[61] gtk_widget_event_internal(0x813d080, 0x80468b0, 0x8046818, 0xfe6bec78),
at 0xfe6bf09c
[62] gtk_widget_send_expose(0x813d080), at 0xfe6becf9
[63] gtk_main_do_event(0x80468b0), at 0xfe590948
[64] gdk_window_process_updates_recurse(0x80e09f8, 0x81d6820, 0x8046938,
0xfe956c90), at 0xfe92774c
[65] _gdk_windowing_window_process_updates_recurse(0x80e09f8), at 0xfe956ca5
[66] gdk_window_process_updates_internal(0x80e09f8), at 0xfe92792e
[67] gdk_window_process_updates(0x80e09f8), at 0xfe927c76
[68] gtk_window_move_resize(0x813d080, 0x0, 0x1, 0xfe6d0bd0), at 0xfe6d1e7b
[69] gtk_window_check_resize(0x813d080, 0x8108bc0, 0x0, 0xfedeab82), at
0xfe6d0bf6
[70] g_cclosure_marshal_VOID
_VOID(0x8110138, 0x0, 0x1, 0x8166160, 0x8046c98,
0xfe6d0bc4, 0x8046b98, 0xfedd295c), at 0xfedeabd1
[71] g_type_class_meta_marshal(0x8110138, 0x0, 0x1, 0x8166160, 0x8046c98,
0x174), at 0xfedd2996
[72] g_closure_invoke(0x8110138, 0x0, 0x1, 0x8166160, 0x8046c98, 0xfee11630,
0x8046cb0, 0x0), at 0xfedd26a1
[73] signal_emit_unlocked_R(0x80e5c18, 0x0, 0x813d080, 0x0, 0x8166160,
0x813d080, 0x0, 0xfede8481), at 0xfedea1f5
[74] g_signal_emit_valist(0x813d080, 0x52, 0x0, 0x8046e5c), at 0xfede8dbe
[75] g_signal_emit(0x813d080, 0x52, 0x0, 0xfe50f634), at 0xfede8f25
[76] gtk_container_check_resize(0x813d080, 0xfeda1a7c, 0x8046e98,
0xfe50f426), at 0xfe50f65c
[77] gtk_container_idle_sizer(0x0, 0x0, 0x8046eb8, 0xfe904f70), at 0xfe50f461
[78] gdk_threads_dispatch(0x8155f50, 0xfeda1a7c, 0x8046ee8, 0xfecd5564), at
0xfe904f8f
[79] g_idle_dispatch(0x8137ee8, 0xfe904f4c, 0x8155f50, 0x8046f40), at 0xfecd557a
[80] g_main_dispatch(0x80d5ea8, 0xfeda1a7c, 0x8046fe8, 0xfecd2f9a), at
0xfecd1bb3
[81] g_main_context_dispatch(0x80d5ea8, 0x6e, 0x82cb648, 0xa), at 0xfecd3023
[82] g_main_context_iterate(0x80d5ea8, 0x1, 0x1, 0x80a7490), at 0xfecd3428
[83] g_main_loop_run(0x80a6bc0, 0x80a6bc0, 0x812b958, 0xfe59002a), at 0xfecd3a1c
[84] gtk_main(0x805517c, 0xfef50100, 0x0, 0x80a7160, 0xfeee7be6, 0xfec70140),
at 0xfe5900d6
[85] main(0x1, 0x8047108, 0x8047110, 0x80470fc), at 0x806b8b0
(dbx)

Actions #1

Updated by Ken Mays about 8 years ago

  • Assignee set to OI JDS
Actions #2

Updated by Alexander Pyhalov about 8 years ago

It seems to be related to nimbus theme... Can't reproduce it, e.g. with clearlooks.
With nimbus gdb shows

Program terminated with signal 11, Segmentation fault.
[New process 66924 ]
[New process 132460 ]
#0 0xfe057e71 in from_mozilla_widget ()
from /usr/lib/gtk-2.0/2.10.0/engines/libnimbus.so
(gdb) bt
#0 0xfe057e71 in from_mozilla_widget ()
from /usr/lib/gtk-2.0/2.10.0/engines/libnimbus.so
#1 0xfe05cc7d in draw_slider ()
from /usr/lib/gtk-2.0/2.10.0/engines/libnimbus.so
#2 0xfe61cbe6 in gtk_paint_slider ()
from /usr/lib/libgtk-x11-2.0.so.0
#3 0xfe5d52fe in gtk_range_expose ()
from /usr/lib/libgtk-x11-2.0.so.0
#4 0xfe592fc4 in gtk_marshal_BOOLEAN_BOXED ()
from /usr/lib/libgtk-x11-2.0.so.0
#5 0xfedd2996 in g_type_class_meta_marshal ()

Actions #3

Updated by Milan Jurik about 8 years ago

  • Category set to Desktop (JDS)
  • Assignee changed from OI JDS to Milan Jurik
  • % Done changed from 0 to 20
  • Tags deleted (needs-triage)
Actions #4

Updated by Udo Grabowski over 7 years ago

Not fixed in a9.

Actions #5

Updated by Ken Mays about 7 years ago

  • Status changed from New to Rejected
  • Assignee changed from Milan Jurik to Ken Mays
  • % Done changed from 20 to 0

Won't fix. Use Clearlooks or a better theme at this time (this will become the default versus Nimbus in future releases).

Actions

Also available in: Atom PDF