Project

General

Profile

Bug #3900

illumos will not build against gcc compiled perl

Added by Alexander Pyhalov about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Start date:
2013-07-20
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

Previous title: cw doesn't understand gnu c options

The problem is that cw expects to get Studio options, including -KPIC and -xO3.
When it receives -fPIC -DPIC and -O3, it fails. These options can come from perl makemaker. And perl makemaker gets them from current perl environment.
It seems that cw should be updated to understand GCC options (at least -On and -fPIC/-fpic/-DPIC).


Files

Config.pm (2.52 KB) Config.pm Alexander Pyhalov, 2013-08-02 09:40 AM
Config_heavy.pl (29.6 KB) Config_heavy.pl Alexander Pyhalov, 2013-08-02 09:40 AM
Config_gcc.p5m (3.07 KB) Config_gcc.p5m Alexander Pyhalov, 2013-08-02 09:40 AM
Config_heavy_gcc.p5m (37.1 KB) Config_heavy_gcc.p5m Alexander Pyhalov, 2013-08-02 09:40 AM
cw_diff.patch (618 Bytes) cw_diff.patch Patch Prasad Joshi, 2013-08-08 06:25 PM

Related issues

Related to illumos gate - Bug #4723: Remove unused perl extensionsResolved2014-04-03

Actions

History

#1

Updated by Prasad Joshi about 6 years ago

Hi Alexander Pyhalov,

Are you working on solving this problem?

Incase you are not, I would like to work on it. Would it be possible for you to upload more information about the problem like
1. Your Perl environment settings. I could have the same environment at my location to reproduce the problem.
2. Perl Module: It would be good to have the perl module which showed this problem. I hope you would be able to share it.

Thanks and Regards,
Prasad

#2

Updated by Alexander Pyhalov about 6 years ago

Hello.
No, I currently don't work on the problem. I've attached configs of gcc-built perl 5.16 and perl 5.10 built by Sun Studio. It doesn't matter what module you trying to build (you can try, for example, XML-Simple), just set CC to gcc and use makemaker to generate build file. I worked around this problem by explicitly setting makemaker arguments on command line.

#3

Updated by Prasad Joshi about 6 years ago

  • Assignee set to Prasad Joshi
#4

Updated by Prasad Joshi about 6 years ago

Attaching the patch which should fix this problem. However, I am not very sure if this should at all be fixed.

As far as I can think, CW was added as to map Sun Studio switches to possible GCC switches. This feature requests a to add few switches, which are specific to GCC.

#5

Updated by Andrew Stormont over 5 years ago

  • Status changed from New to Feedback

This isn't the way to fix perl, especially since we already have perlgcc (see http://search.cpan.org/~aburlison/Solaris-PerlGcc-1.3/pod/perlgcc.pod) in illumos gate. Somewhere along the line we must have broken support for building the perl modules with perlgcc (probably when most of the perl stuff was ripped out) but it looks pretty simple to fix. I'll see if I can knock out a patch.

#7

Updated by Andrew Stormont over 5 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Prasad Joshi to Andrew Stormont

I've updated the title to reflect what I think the real problem is. I will update the webrev with feedback from Igor when I get some free cycles and then put it up for review.

#8

Updated by Andrew Stormont over 5 years ago

  • Subject changed from cw doesn't understand gnu c options to illumos will not build against gcc compiler perl

Lets have another go at changing the title.

#9

Updated by Andrew Stormont over 5 years ago

  • Subject changed from illumos will not build against gcc compiler perl to illumos will not build against gcc compiled perl
#10

Updated by Electric Monk over 5 years ago

git commit c9f77c52c0735e65aa2534394c5151cdb963cbef

Author: Andy Stormont <astormont@racktopsystems.com>

3900 illumos will not build against gcc compiled perl
4723 Remove unused perl extensions
Reviewed by: Keith Wesolowski <keith.wesolowski@joyent.com>
Reviewed by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
Approved by: Dan McDonald <danmcd@omniti.com>

#11

Updated by Electric Monk over 5 years ago

git commit c7893124ebf2d6bb539e1e46fd7f54b8a9af6e6f

Author: Richard Lowe <richlowe@richlowe.net>

3900 illumos will not build against gcc compiled perl (fix studio, pkg, incremental)

#12

Updated by Robert Mustacchi over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Also available in: Atom PDF