Project

General

Profile

Actions

Bug #3979

closed

sdev dynamic directories can be created multiple times

Added by Robert Mustacchi almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
kernel
Start date:
2013-08-04
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

sdev has a simple matching system to determine if it should switch about its vnops for special types of dyanmic nodes. If you create another one of these you now have two copies of these nodes in the namespace, definitely not quite an intended behavior.

The solution here is to ensure that you are only under /dev when these are created. This was part of the original intent of the system as far as we can tell. Having dynamic directories at any point in the name space is tricky and requires a lot of careful though. As such, until we have such a need for something we are restricted to doing what we know is safe.

Actions #1

Updated by Robert Mustacchi over 7 years ago

  • Status changed from New to Resolved

Resolved in 9e5aa9d8a21f8efa8ba9c9e4a0aa6edc66d07eb2.

Actions

Also available in: Atom PDF