Project

General

Profile

Bug #4040

151a8/dev Wrong library name for gnome svg loader

Added by Udo Grabowski over 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-08-13
Due date:
2014-02-06
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
jds

Description

A couple of JDS programs (eog, netstat monitor) complain about '/usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so
not found'. This library actually has a different name, so workaround is to link the new name to that one:
ln -s libpixbufloader-svg.so svg_loader.so

History

#1

Updated by Ken Mays over 6 years ago

  • Assignee set to OI JDS
#2

Updated by Milan Jurik over 6 years ago

  • Assignee changed from OI JDS to Milan Jurik
  • Tags deleted (needs-triage)
#3

Updated by Milan Jurik over 6 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

I will add backward compatibility symlink for now.

#4

Updated by Udo Grabowski almost 6 years ago

This is strange on a9, /usr/lib/gtk-2.0/2.10.0/loaders is gone, there's a /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders dir,
but symlinking there and symlinking it back to gtk-2.0 does not solve the problem anymore (eog can't recognize SVG).
But eog does (strange...) NOT complain about the missing library !? What changed ?

#5

Updated by Milan Jurik almost 6 years ago

  • % Done changed from 90 to 10
  • Difficulty changed from Bite-size to Medium

Udo Grabowski wrote:

This is strange on a9, /usr/lib/gtk-2.0/2.10.0/loaders is gone, there's a /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders dir,
but symlinking there and symlinking it back to gtk-2.0 does not solve the problem anymore (eog can't recognize SVG).
But eog does (strange...) NOT complain about the missing library !? What changed ?

gdk-pixbuf contains the svg loader in new version of gdk, used by gtk. The is some other issue with eog now.

#6

Updated by Milan Jurik almost 6 years ago

  • % Done changed from 10 to 70

Workaround:

As root do (on a9):

/usr/bin/gdk-pixbuf-query-loaders > /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

The root cause is in wrong loaders.cache, not re-generated after librsvg installation.

#7

Updated by Udo Grabowski almost 6 years ago

That fixed the problem, thanks !

#8

Updated by Ken Mays almost 6 years ago

  • Due date set to 2014-02-06
  • Category set to Desktop (JDS)
  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100
  • Estimated time set to 1.00 h
  • Tags set to jds

User confirmed workaround/fix. Closing ticket. (Possibly can create a post script after librsvg install to initialize).

Also available in: Atom PDF