Project

General

Profile

Bug #4041

151a8 Pidgin dumps core

Added by Nikola M. almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-08-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

After updating from 151a7 to 151a8, (64-bit)
trying to start and use Pidgin internet messenger, leads to core dump.

$ pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org origin online http://pkg.openindiana.org/dev/
sfe (non-sticky) origin online http://pkg.openindiana.org/sfe/
sfe-encumbered (non-sticky) origin online http://pkg.openindiana.org/sfe-encumbered/

$ pidgin

(Pidgin:1140): GLib-WARNING **: g_set_application_name() called multiple times
Pidgin 2.10.7 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file. If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace
Abort (core dumped)

Core dump (29M 7z):
https://mega.co.nz/#!KkBDxDST!R8JNGhJjmyx_mR7HJKJTDh03I5dNLpkZE7dGaVNsrFY


Files

pidgin-data.txt (3.01 KB) pidgin-data.txt Nikola M., 2013-08-17 04:45 AM
pidgin-pkg_list.txt (83.8 KB) pidgin-pkg_list.txt Nikola M., 2013-08-17 04:45 AM

History

#1

Updated by Ken Mays almost 7 years ago

  • Assignee set to OI JDS
#2

Updated by Jon Tibble almost 7 years ago

  • Status changed from New to Feedback

I couldn't reproduce this on my install. Could you give us the output of the following please:

which pidgin
pidgin --version
ldd -r `which pidgin`
pkg list

Thanks.

#3

Updated by Milan Jurik almost 7 years ago

core 'core' of 3027: pidgin
feef4b75 lwp_kill (1, 6, 8046a38, fee884ce) + 15
fee884da raise (6, 0, 8046a88, fee5fcaa) + 22
fee5fcca abort (b, 0, 8046b60, 8433660, feec9544, febb2a40) + f2
feeefc25 __sighndlr (b, 0, 8046b60, 80d755c) + 15
feee298e call_user_handler (b) + 2a2
feee2bd2 sigacthandler (b, 0, 8046b60) + f2
--- called from signal handler with signal 11 (SIGSEGV) ---
fd992a22 generate_prediction_for (85492f8) + 29e
fd992761 generate_prediction (8ab0178, 8a1ec68, 8ab0178, fd992a8a) + 49
fd992b1b get_stats_for (85492f8, fe9744fc, 8548d80, fec7072a) + 9f
fd993482 buddy_signed_on (85492f8, 0, 30203a5, 8548cd8, fe9744fc, fe99e910) + e
fe92b22d purple_marshal_VOID
_POINTER (fd993474, 8046ec8, 0, 0) + 11
fe92ae24 purple_signal_emit_vargs (fe9a36c4, fe9744fc, 8046ec8, fe92ad1c) + 84
fe92ad3f purple_signal_emit (fe9a36c4, fe9744fc, 85492f8, fe8e9b0b) + 2f
fe8e9b1f purple_blist_update_buddy_status (85492f8, 8548d80, 8046f4c, fe92134e) + 147
fe92140b purple_prpl_got_user_status (8219f60, 89dda08, fd4817f8, fd482adc, 18, fd48241c) + cb
fd471c7e handle_presence_contact (899b258, 8046fd0, 8a50518, fd471d46) + 252
fd472125 jabber_presence_parse (899b258, 8a4fb78, 85df740, 804709c) + 3ed
fd45c9b9 jabber_process_packet (899b258, 804709c, fcb377c4, fd46f4b1) + 2ed
fd46f4fc jabber_parser_element_end_libxml (899b258, 8a2f677, 0, 8a2f47b) + 58
fca69d70 xmlParseEndTag2 (8a2bf20, 0, 8a2f47b, 0, 0) + 244
fca6ccd8 xmlParseTryOrFinish (8a2bf20, 0, fd495f00, fca6e212) + 3d4
fca6e4ea xmlParseChunk (8a2bf20, fd495f00, 16e, 0) + 2e6
fd46f66d jabber_parser_process (899b258, fd495f00, 16e, fd495f00) + 2d
fd45d309 jabber_recv_cb_ssl (85df740, 8194790, 1, fec84238, 813bd20, fed51538) + b5
fe93442a recv_cb (8194790, c, 1, fec83cce) + 16
080bedae pidgin_io_invoke (89a1850, 1, 82e6e10, fecc9ece) + 3a
fecc9f02 g_io_unix_dispatch (85bc9a8, 80bed74, 82e6e10, 80473b0) + 42
fec81573 g_main_dispatch (813bd20, fed51538, 8047458, fec8295a) + 1df
fec829e3 g_main_context_dispatch (813bd20, 0, 89a8110, a) + 93
fec82de8 g_main_context_iterate (813bd20, 1, 1, 8138610) + 3a8
fec833dc g_main_loop_run (85bfaa0, 85bfaa0, 81aac38, fe39002a) + 1d8
fe3900d6 gtk_main (8047510, fee69376, 0, 0, 0, 1) + ba
080d8599 main (1, 8047ab4, 8047abc, 8088f1f) + 901
08088f67 _start (1, 8047bb4, 0, 8047bbb, 8047be2, 8047c1f) + 67

It is from xmpp (or Facebook?). I guess this is the fix:

--- pidgin-2.10.7/pidgin/plugins/cap/cap.c~ 2013-02-11 04:16:54.000000000 0500
++ pidgin-2.10.7/pidgin/plugins/cap/cap.c 2013-02-14 10:44:27.743029516 -0500
@ -43,7 +43,7 @
int threshold = purple_prefs_get_int("/plugins/gtk/cap/threshold");
int min_minute = (current_minute - threshold) % 1440;
int max_minute = (current_minute + threshold) % 1440;
char *sql, sta_id = NULL;
char *sql, *sta_id = NULL;
sqlite3_stmt *stmt = NULL;
const char *tail = NULL;
int rc;

I cannot reproduce it myself but reports on the Net are frequent.

#4

Updated by Milan Jurik almost 7 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from OI JDS to Milan Jurik
  • % Done changed from 0 to 50
  • Tags deleted (needs-triage)
#5

Updated by Nikola M. almost 7 years ago

Jon Tibble wrote:

I couldn't reproduce this on my install. Could you give us the output of the following please:

which pidgin
pidgin --version
ldd -r `which pidgin`
pkg list

Here they are:
$ which pidgin
/usr/bin/pidgin
$ pidgin --version
Pidgin 2.10.7 (libpurple 2.10.7)

#6

Updated by Milan Jurik over 6 years ago

  • Category set to Desktop (JDS)
  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Fixed in a9

Also available in: Atom PDF