Project

General

Profile

Bug #4059

oi_151a8 does not recognize an audio CD

Added by Gary Mills over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-08-19
Due date:
2014-01-24
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
audiocd

Description

I noticed this problem on two separate machines that I upgraded from oi_151a7 to oi_151a8. When I insert an audio CD in the drive, the drive light flashes several times but the audio CD icon does not appear on the desktop. Consequently, the Rhythmbox music player doesn't display the tracks on the CD. This all works on oi_151a7.

The oi_151a8 system does automatically mount and display an OS DVD with an icon and the file manager when I insert it in the drive.

This is the `lshal --monitor' output when I insert an audio CD:

    pci_0_0/pci_ide_d/ide_0_0/sd0/sd0 property storage.removable.media_available = true
    pci_0_0/pci_ide_d/ide_0_0/sd0/sd0 property storage.removable.solaris.read_only = true
    pci_0_0/pci_ide_d/ide_0_0/sd0/sd0/s2 added

This syslog message, along with many others, also appears at that time:

    Aug 19 14:50:29 amd hald[573]: [ID 702911 daemon.warning] 14:50:29.465 [W] hald_dbus.c:89: No property info.claimed on device with id /org/freedesktop/Hal/devices/pci_0_0/pci_ide_d/ide_0_0/sd0/sd0

History

#1

Updated by Ken Mays over 6 years ago

  • Assignee changed from Guido Berhörster to OI JDS
#2

Updated by Gary Mills about 6 years ago

  • Status changed from New to Feedback

After I upgraded this machine to oi_151a9, I found that it's still unable to mount an audio CD when it's inserted in the drive. No icon appears on the desktop. The audio player does not start. This worked under oi_151a7. What changed?

#3

Updated by Udo Grabowski about 6 years ago

CD can be played with Rythmbox on a9 without problems.
Gary: Maybe you are not entitled to use pfexec ? I've seen several bugs on a8 when a totally unprivileged user tries
to do anything with devices.

#4

Updated by Gary Mills about 6 years ago

Does that mean that when you insert a CD in the drive that an icon appears on the desktop and that rhythmbox starts automatically? It doesn't do either for me under oi_151a9.

How do I determine if I'm entitled to use pfexec? I've never used it explicitly. Instead I use `su' in a terminal window. This test seems to show that it works:

<mills@amd:841>$ id
uid=107(mills) gid=10(staff)
<mills@amd:843>$ pfexec id
uid=0(root) gid=0(root)

Something's different. What should I check now?

#5

Updated by Ken Mays about 6 years ago

  • Due date set to 2014-01-24
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to audiocd

Gary,

On hipster 2014-01-24 (a7-based, illumos-a11c157),

1. rmformat - will tell you about the CD/DVD device player and access permissions.
2. /usr/bin/sound-juicer - plays audio CDs and is a CD 'ripper' for GNOME.
3. Rhythmbox - music management.

I just ran Sound-juicer 2.28.2 and it picks up my audio tracks and durations correctly. Automounting, puts the audio CD icon on the screen as well and in Nautilus.

#6

Updated by Ken Mays about 6 years ago

  • Status changed from Closed to Feedback
#7

Updated by Ken Mays about 6 years ago

  • Status changed from Feedback to Closed

This works properly in hipster with the latest kernel as of today. Decommission oi_151a8 usage due to known issues with JDS (migrate to hipster, if possible).

#8

Updated by Gary Mills about 6 years ago

  • Status changed from Closed to Feedback

This is a test of the newly-releases oi_151a9 distribution. Hipster is not involved. With an audio CD in the drive, I see this:

$ rmformat
Looking for devices...
1. Logical Node: /dev/rdsk/c7t0d0p0
Physical Node: /pci@0,0/pci-ide@d/ide@0/sd@0,0
Connected Device: HL-DT-ST DVD-RAM GSA-H55N 1.05
Device Type: CD Reader
Bus: IDE
Size: 435.8 MB
Label: <None>
Access permissions: Medium is not write protected.

This machine also has sound-juicer installed. When I run it from the command-line with the audio CD inserted, a dialogue box appears that says:

No CD-ROM drives found
Sound juicer could not find any CD-ROM drives to read

#9

Updated by Ken Mays almost 6 years ago

  • % Done changed from 100 to 0

Ok. Loaded oi_151a8. My drive detects DVDs and data DVDs properly with their icons, and audio CDs get detected but is no-go with the audio icon or proper mounting for rhythmbox or sound-juicer to automatically play the audio CD (same procedure works on a7/hipster installs). Bug confirmed.

Need to check JDS rebuild. Brasero was missing some patches...

#10

Updated by Ken Mays almost 6 years ago

  • Assignee changed from OI JDS to Milan Jurik
#11

Updated by Gary Mills almost 6 years ago

The problem under oi_151a9 was solved by installing the gvfs package. `pkg info gvfs' showed that it was not installed. I used `pkg install gvfs' to install it, followed by a desktop logout and login.

Then, when I inserted an audio CD in the drive, it was mounted automatically and the music player window appeared. The music player worked too!

I don't know why it stopped working when I upgraded from oi_151a7 to oi_151a8, or why that package was never installed when I upgraded again to oi_151a9.

#12

Updated by Milan Jurik almost 6 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

gvfs was obsoleted by mistake during final build of a8. And IPS was not evaluating it for update from a8 to a9 because it was obsoleted.

Also available in: Atom PDF