Project

General

Profile

Actions

Bug #4068

closed

Upgrade from oi_148 fails due to "Unknown type (conditional) in depend action"

Added by Joseph Ellis almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Category:
PKG (Image Packaging System)
Target version:
-
Start date:
2013-08-21
Due date:
2014-02-06
% Done:

100%

Estimated time:
2.00 h
Difficulty:
Medium
Tags:
pkg

Description

Following the upgrade guide here http://wiki.openindiana.org/oi/Upgrading+OpenIndiana

sequence so far is as follows (as root):

  1. pkg unset-publisher opensolaris.org
Verified publisher as follows:
  1. pkg publisher
    PUBLISHER TYPE STATUS URI
    openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/

#pkg refresh --full

#pkg image-update -nv

image update fails with

pkg: The requested operation cannot be completed due to invalid package metadata. Details follow:

invalid action in package pkg:,5.11-0.151.1.8:20130721T131442Z: depend fmri=library/python-2/tkinter-26 predicate=runtime/tk-8 type=conditional: Unknown type (conditional) in depend action

Seems similar to https://www.illumos.org/issues/2629

Have run through troubleshooting here, gotten nowhere: http://wiki.openindiana.org/oi/Troubleshooting+image-update+failures

Actions #1

Updated by Ken Mays almost 8 years ago

  • Assignee set to Andrzej Szeszo
Actions #2

Updated by Joseph Ellis almost 8 years ago

Forgot to mention, the first time I tried to do an image-update it asked me to update pkg, which I did.

  1. pkg list package/pkg

NAME (PUBLISHER) VERSION STATE UFOXI
package/pkg 0.5.11-0.148 installed u----

It doesn't really appear to have updated to the latest version of pkg, however (unless I'm reading this wrong)

Ideas? Is there some way to force the latest version of pkg to install?

Attempting to update pkg again does nothing:

  1. pkg install pkg:/package/pkg
    No updates necessary for this image.
Actions #3

Updated by Piotr Jasiukajtis over 7 years ago

You may try this workaround:

Create a copy of package/pkg from another oi_151a8 machine:

pkg contents -H package/pkg | ( cd / && cpio -pdumv /pkg_package_archive/ )

and extract those files on an old 148 build.

Remember to create a backup BE using 'beadm create' first.

Actions #4

Updated by Steven Williamson over 7 years ago

Following the page on the Openindiana wiki to upgrade from Opensolaris 134 to Openindiana I hit the bug reported here.
Checking the version of pkg on my system opensolaris snv_134 I can confirm the code does not contain the conditional depend action.

This is preventing upgrade as the unsupported condition appears to be in the metadata for when of the packages in the repo.

To upgrade it seems like I first need to be able to install a version of "pkg" that does support the conditional depend but at this time that does not seem possible.

Speaking in the irc Openindiana IRC channel as I was asked to try upgrading to different versions of "entire" all of which fail with the same problem.

Actions #5

Updated by Daniel Bakken over 7 years ago

I hit the same bug following the upgrade guide to upgrade OpenSolaris 134 to OpenIndiana 151:

root@trogdor:~# pkg image-update -v --be-name openindiana
Creating Plan /
pkg: The requested operation cannot be completed due to invalid package metadata.  Details follow:

invalid action, 'depend fmri=library/python-2/tkinter-26 predicate=runtime/tk-8 type=conditional': Unknown type (conditional) in depend action

I would love to upgrade to OI but this has stopped me cold.

Actions #6

Updated by Jon Tibble over 7 years ago

  • Status changed from New to Feedback

This should be fixed in the /dev repo now so anyone who was hitting this should retry and confirm.

Actions #7

Updated by Ken Mays over 7 years ago

  • Tags changed from needs-triage to pkg
  • Due date set to 2014-02-06
  • Category set to PKG (Image Packaging System)
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100
  • Estimated time set to 2.00 h

Be sure to have openindiana sticky, opensolaris (if still installed)
non-sticky, sfe non-sticky, sfe-encumbered sticky, the rest should be
non-sticky.

Tested oi_134/oi_151a migrations to oi_151a9. Successful.

Actions

Also available in: Atom PDF